summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-10-20 21:27:56 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-10-22 11:26:37 +0300
commit2e15fa07689690e90dfa997403b7c950a4308aea (patch)
tree02092be18a1b11b465b3762ddc320d96d86cfe9a /gnu/packages
parent181f5c20a8d9026c5ac4659ba80dc0abf76a94f6 (diff)
gnu: Add rust-aes-ctr-0.6.
* gnu/packages/crates-io.scm (rust-aes-ctr-0.6): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 75268ad55e..093936e15d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2219,6 +2219,32 @@ ciphers implementations.")
("rust-aesni" ,rust-aesni-0.6)
("rust-block-cipher-trait" ,rust-block-cipher-trait-0.6))))))
+(define-public rust-aes-ctr-0.6
+ (package
+ (name "rust-aes-ctr")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "aes-ctr" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0qspjxzrclnb83501595y01dhc0km1ssrbjnwlxhcrsdwp6w6abp"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:cargo-inputs
+ `(("rust-aesni" ,rust-aesni-0.10)
+ ("rust-aes-soft" ,rust-aes-soft-0.6)
+ ("rust-cipher" ,rust-cipher-0.2)
+ ("rust-ctr" ,rust-ctr-0.6))
+ #:cargo-development-inputs `(("rust-cipher" ,rust-cipher-0.2))))
+ (home-page "https://github.com/RustCrypto/block-ciphers/tree/master/aes")
+ (synopsis "Pure Rust implementation of AES")
+ (description
+ "A pure Rust implementation of the @acronym{AES, Advanced Encryption
+Standard}. Use the AES crate if possible, as the aes-ctr has been into it.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-aes-gcm-0.10
(package
(name "rust-aes-gcm")