summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-08-19 11:00:34 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-19 16:01:27 +0200
commit2ecd8b2e0ed36864e842396c20b17a0833c03172 (patch)
tree5bb615352c4721e7c0d7163a2d4530c77a2c6b83 /gnu/packages
parent410e9f1dbddf65194dd936288e581ceeeb840fe9 (diff)
gnu: gjs: Update to 1.68.2.
* gnu/packages/gnome.scm (gjs): Update to 1.68.2. [source]: Move a pre-check phase substitution to a snippet. [build-system]: Switch to meson. [arguments]<#:configure-flags>: Do not install tests. <#:phases>: Remove pre-check phase substitutions. [propagated-inputs]: Switch to mozjs 78.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm42
1 files changed, 19 insertions, 23 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a92b625c21..49587dd427 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7088,7 +7088,7 @@ configuration program to choose applications starting on login.")
(define-public gjs
(package
(name "gjs")
- (version "1.58.3")
+ (version "1.68.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -7096,30 +7096,26 @@ configuration program to choose applications starting on login.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1bkksx362007zs8c31ydygb29spwa5g5kch1ad2grc2sp53wv7ya"))))
- (build-system gnu-build-system)
+ "0c7fclm53v41n5vfndymp35fbh1x218lrk65iqrk1wc2lsnh5zvh"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "installed-tests/scripts/testCommandLine.sh"
+ (("Valentín") "")
+ (("☭") ""))))))
+ (build-system meson-build-system)
(arguments
- '(#:phases
+ '(#:configure-flags '("-Dinstalled_tests=false")
+ #:phases
(modify-phases %standard-phases
- (add-before
- 'check 'pre-check
- (lambda _
- ;; The test suite requires a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")
-
- ;; For the missing /etc/machine-id.
- (setenv "DBUS_FATAL_WARNINGS" "0")
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; The test suite requires a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
- ;; Our mozjs-38 package does not compile the required Intl API
- ;; support for these failing tests.
- (substitute* "installed-tests/js/testLocale.js"
- ((".*toBeDefined.*") "")
- ((".*expect\\(datestr\\).*") ""))
- (substitute* "installed-tests/scripts/testCommandLine.sh"
- (("Valentín") "")
- (("☭") ""))
- #t)))))
+ ;; For the missing /etc/machine-id.
+ (setenv "DBUS_FATAL_WARNINGS" "0"))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-resources
("pkg-config" ,pkg-config)
@@ -7133,7 +7129,7 @@ configuration program to choose applications starting on login.")
;; These are all in the Requires.private field of gjs-1.0.pc.
`(("cairo" ,cairo)
("gobject-introspection" ,gobject-introspection)
- ("mozjs" ,mozjs-60)))
+ ("mozjs" ,mozjs-78)))
(inputs
`(("gtk+" ,gtk+)
("readline" ,readline)))