summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-11 23:01:03 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:18 +0800
commit370c8bd78b06314dc860695a6aad820c209e1386 (patch)
tree18b86d71bd4dd0e765b53346025ba087a9592a95 /gnu/packages
parentd546023c865b819c3d56d66b2e43ae6642300390 (diff)
gnu: Add python-towncrier.
* gnu/packages/python-xyz.scm (python-towncrier): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 927c031869..0dd94edf8a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24096,6 +24096,40 @@ standard library. It provides two additional tokens @code{ESCAPED_NL} and
and @code{tokens_to_src} to roundtrip.")
(license license:expat)))
+(define-public python-towncrier
+ (package
+ (name "python-towncrier")
+ (version "23.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "towncrier" version))
+ (sha256
+ (base32
+ "1hbhzxcn30qlnab1rnk2bf09jfy5bpxzfdp6zfn8sz3jnidbsagw"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:test-flags
+ ;; TODO: Why is this failing?
+ #~'("-k" "not test_version")))
+ (propagated-inputs
+ (list python-click
+ python-click-default-group
+ python-incremental
+ python-jinja2
+ python-tomli))
+ (native-inputs
+ (list git-minimal/pinned ;tests create git repositories
+ python-hatchling
+ python-packaging
+ python-pytest
+ python-twisted))
+ (home-page "https://towncrier.readthedocs.io/en/stable/")
+ (synopsis "Manage release notes")
+ (description
+ "@code{towncrier} is a utility to produce useful, summarized news
+files (also known as changelogs) for a project.")
+ (license license:expat)))
+
(define-public python-future-fstrings
(package
(name "python-future-fstrings")