summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-26 11:42:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-27 09:11:12 +0300
commit3ccec0598dfb0cb3bd75317c94995529363eb352 (patch)
tree87069f2519902753ea6fcf95d64dcbfaeb14ac0b /gnu/packages
parent488a39503a240761f8a806c01543e5148a5624e0 (diff)
gnu: system-config-printer: Fix build on riscv64-linux.
* gnu/packages/gnome.scm (system-config-printer)[arguments]: When config is an input add a phase to replace config.guess and config.sub. [native-inputs]: Add config when building for riscv64-linux. Change-Id: Iad0d2cbadd9c9f90b88e97e7690ad3b0ad0e6882
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm34
1 files changed, 24 insertions, 10 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cbc2c97296..30d87e2b6c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3019,6 +3019,16 @@ guidelines.")
(substitute* "Makefile.am"
(("/bin/bash") (which "bash")))
(delete-file "configure")))
+ #$@(if (this-package-native-input "config")
+ #~((add-after 'unpack 'update-config-scripts
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub")))))
+ #~())
(add-after 'install 'add-install-to-pythonpath
(@@ (guix build python-build-system) add-install-to-pythonpath))
(add-after 'add-install-to-pythonpath 'wrap-for-python
@@ -3051,16 +3061,20 @@ guidelines.")
libnotify
packagekit))
(native-inputs
- (list pkg-config
- desktop-file-utils
- glib
- autoconf
- automake
- gettext-minimal
- xmlto
- docbook-xml-4.1.2
- docbook-xsl
- libxml2))
+ (append
+ (if (target-riscv64?)
+ (list config)
+ '())
+ (list pkg-config
+ desktop-file-utils
+ glib
+ autoconf
+ automake
+ gettext-minimal
+ xmlto
+ docbook-xml-4.1.2
+ docbook-xsl
+ libxml2)))
(home-page "https://github.com/zdohnal/system-config-printer")
(synopsis "CUPS administration tool")
(description