summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-03-10 16:29:36 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-05-27 09:31:47 +0800
commit473cdecd8965a301ef6817027090bc61c6907a18 (patch)
treef29b37ff9355507abd8e4904069f439069e53a59 /gnu/packages
parentf119408f2f7628b22625416f583d236cb885ef51 (diff)
gnu: freegish: Update to 0-3.caf58a2f9.
* gnu/packages/games.scm (freegish): Update to 0-3.caf58a2f9. [inputs]: Replace sdl-union with sdl2. Remove zlib. [arguments]: Adjust configure-flags, remove unneeded phases. Change-Id: I43883bd3de985dc337e244a810214ea5ae6aabd1
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm23
1 files changed, 6 insertions, 17 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 73d1ffc008..2c096ea15d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6731,8 +6731,8 @@ Magic, Egypt, Indians, Norsemen, Persian or Romans.")
(license license:gpl2+)))
(define-public freegish
- (let ((commit "21977ee5fc2008231b35160df00efe954c508b16")
- (revision "2"))
+ (let ((commit "caf58a2f990a939230bab82226e29cd79732f366")
+ (revision "3"))
(package
(name "freegish")
(version (string-append "0-" revision "." (string-take commit 9)))
@@ -6744,7 +6744,7 @@ Magic, Egypt, Indians, Norsemen, Persian or Romans.")
(file-name (git-file-name name version))
(sha256
(base32
- "1qh0gcnbyxyzmb13jifwba4xrzj94m4w9whdvl0gnds6ricmwply"))
+ "0980ad8xg0bzm6507bq9sbgw03i7jj33g0f955g0q8jvpb22r65v"))
(modules '((guix build utils)))
;; The audio files in the "music" directory are licensed under
;; CC-BY-NC, so we delete them.
@@ -6756,25 +6756,14 @@ Magic, Egypt, Indians, Norsemen, Persian or Romans.")
(arguments
`(#:tests? #f ; no tests included
#:configure-flags
- (list "-DCMAKE_INSTALL_FHS=ON")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'set-DATAPATH
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "CMakeLists.txt"
- (("^option\\(INSTALL_FHS" line)
- (string-append "add_definitions(-DDATAPATH=\""
- (assoc-ref outputs "out") "/share/freegish\")\n"
- line)))
- #t)))))
+ (list "-DINSTALL_FHS=ON")))
(inputs
- (list (sdl-union (list sdl sdl-mixer))
+ (list sdl2
openal
libvorbis
libogg
mesa
- libpng
- zlib))
+ libpng))
(home-page "https://github.com/freegish/freegish")
(synopsis "Side-scrolling physics platformer with a ball of tar")
(description "In FreeGish you control Gish, a ball of tar who lives