summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-05-25 14:28:20 -0300
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2021-06-23 06:45:20 +0200
commit4b39a6fa14e5b7a4f075d8f980c974560ffc47ad (patch)
treececa7acbeb24006ac063d3d9c0db20202cdda887 /gnu/packages
parentac8fb4b9f4db0cf774799b95fc176c8a80ade6cc (diff)
gnu: Add python-pykdtree.
* gnu/packages/python-xyz.scm (python-pykdtree): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7ff7c1e4cc..ec4209108f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5895,6 +5895,28 @@ operators such as union, intersection, and difference.")
(define-public python2-pysnptools
(package-with-python2 python-pysnptools))
+(define-public python-pykdtree
+ (package
+ (name "python-pykdtree")
+ (version "1.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pykdtree" version))
+ (sha256
+ (base32 "0p8n2ljdacfixkiw092974dmhy4s1c0h032ii1z9kwi9h5h5rgmy"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (home-page "https://github.com/storpipfugl/pykdtree")
+ (synopsis "Fast kd-tree implementation with OpenMP-enabled queries")
+ (description
+ "@code{pykdtree} is a kd-tree implementation for fast nearest neighbour
+search in Python.")
+ (license license:lgpl3+)))
+
(define-public python-wurlitzer
(package
(name "python-wurlitzer")