summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-09-24 12:25:46 +0200
committerjgart <jgart@dismail.de>2024-06-30 22:03:30 -0500
commit5035e6d06d3f67cd40c5c93fbeff22c0af5504a1 (patch)
tree688c10f299270148bd5a0092121c0fe652f874b0 /gnu/packages
parent1a7228b151240de1373bf1c3248bb0277aef0a3e (diff)
gnu: python-django-4.2: Use test-flags argument.
* gnu/packages/django.scm (python-django-4.2): Use test-flags argument. Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/django.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 4060819a35..f07433b10b 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -66,7 +66,12 @@
"1ha6c5j3pizbsfzw37r52lvdz8z5lblq4iwa99mpkdzz92aiqp2y"))))
(build-system python-build-system)
(arguments
- '(#:phases
+ '(#:test-flags
+ (list
+ ;; By default tests run in parallel, which may cause various race
+ ;; conditions. Run sequentially for consistent results.
+ "--parallel=1")
+ #:phases
(modify-phases %standard-phases
(add-before 'check 'pre-check
(lambda* (#:key inputs #:allow-other-keys)
@@ -85,16 +90,12 @@
(string-append " @unittest.skipIf(True, 'Disabled by Guix')\n"
all)))))
(replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
(if tests?
(with-directory-excursion "tests"
;; Tests expect PYTHONPATH to contain the root directory.
(setenv "PYTHONPATH" "..")
- (invoke "python" "runtests.py"
- ;; By default tests run in parallel, which may cause
- ;; various race conditions. Run sequentially for
- ;; consistent results.
- "--parallel=1"))
+ (apply invoke "python" "runtests.py" test-flags))
(format #t "test suite not run~%"))))
;; XXX: The 'wrap' phase adds native inputs as runtime dependencies,
;; see <https://bugs.gnu.org/25235>. The django-admin script typically