summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-17 22:53:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:18 -0400
commit53416dbe59e9cf947c5b0bddf3e98846ac013cfa (patch)
tree138361ae71fe579124b9f65230a37f1994f12bf0 /gnu/packages
parent2c54d3f48934c7515bb85b0ef575aec4ce64ad25 (diff)
gnu: Add python-hatch-fancy-pypi-readme.
* gnu/packages/python-build.scm (python-hatch-fancy-pypi-readme): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-build.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index c5185a77fb..70719c44d4 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -676,6 +676,27 @@ has features such as:
@end itemize")
(license license:expat)))
+(define-public python-hatch-fancy-pypi-readme
+ (package
+ (name "python-hatch-fancy-pypi-readme")
+ (version "22.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hatch_fancy_pypi_readme" version))
+ (sha256
+ (base32
+ "0sn2wsfbpsbf2mqhjvw62h1cfy5mz3d7iqyqvs5c20cnl0n2i4fs"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ;avoid extra test dependencies
+ (propagated-inputs (list python-hatchling python-tomli
+ python-typing-extensions))
+ (home-page "https://github.com/hynek/hatch-fancy-pypi-readme")
+ (synopsis "Fancy PyPI READMEs with Hatch")
+ (description "This hatch plugin allows defining a project description in
+terms of concatenated fragments that are based on static strings, files and
+parts of files defined using cut-off points or regular expressions.")
+ (license license:expat)))
+
(define-public python-hatch-vcs
(package
(name "python-hatch-vcs")