summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-13 14:46:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-14 14:09:35 +0200
commit53c7162174d5fdbe76968809b4ecff20a8327e6b (patch)
tree53407e81534dbfc5f334f9a9f2c63c91409bb3e9 /gnu/packages
parent4699de59ff7c2904a8aed4b7d7cbd96178946d68 (diff)
gnu: Add r-word2vec.
* gnu/packages/cran.scm (r-word2vec): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 89af513c8b..006763ecf7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17215,6 +17215,29 @@ Kingsbury (1999, 2001) as implemented by Selesnick; and Hilbert wavelet
pairs (Selesnick 2001, 2002).")
(license license:bsd-3)))
+(define-public r-word2vec
+ (package
+ (name "r-word2vec")
+ (version "0.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "word2vec" version))
+ (sha256
+ (base32
+ "0qj39vms6zgwb8lpmfkppayizdmhakic3pkacglary3ain61vnsk"))))
+ (properties `((upstream-name . "word2vec")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp r-rcppprogress))
+ (home-page "https://github.com/bnosac/word2vec")
+ (synopsis "Distributed representations of words")
+ (description
+ "Learn vector representations of words by continuous bag of words and
+skip-gram implementations of the word2vec algorithm. The techniques are
+detailed in the paper \"Distributed Representations of Words and Phrases and
+their Compositionality\" by Mikolov et al. (2013), available at
+<arXiv:1310.4546>.")
+ (license license:asl2.0)))
+
(define-public r-wordcloud
(package
(name "r-wordcloud")