summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDariqq <dariqq@posteo.net>2024-05-02 15:37:55 +0000
committerChristopher Baines <mail@cbaines.net>2024-05-15 20:45:08 +0100
commit558e2b07ea0229453a8436b6632198ad2ef2126f (patch)
treeae19c6245160fbbf07199d15f831898913d97379 /gnu/packages
parentd53ce69ba29ea65f9203faa349d8ea47a1bb118d (diff)
gnu: power-profiles-daemon: Build gtk-docs.
* gnu/packages/freedesktop.scm (power-profiles-daemon): [outputs]: Add docs output. [#:configure-flags]: Enable building gtk-docs. [#:phases]: Add a phase to move gtk-docs to docs output. [inputs]: Add gtk-doc/stable, libxslt for docs. Change-Id: I1bc6047858d2b5188e714f39da8b760bc6a71078 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/freedesktop.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 53cae544aa..a77dab5794 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1169,9 +1169,11 @@ manager for the current system.")
(base32
"0dn3ygv49q7mzs52ch3yphxf4hbry698r1ajj52f6jgw7mpwr5p4"))))
(build-system meson-build-system)
+ (outputs '("out" "doc"))
(arguments
(list #:configure-flags #~(list "-Dsystemdsystemunitdir="
"-Dpylint=disabled"
+ "-Dgtk_doc=true"
(string-append "-Dzshcomp=" #$output
"/share/zsh/site-functions/"))
#:phases
@@ -1189,9 +1191,17 @@ manager for the current system.")
"/lib/python"
#$(version-major+minor
(package-version (this-package-input "python")))
- "/site-packages")))))))))
+ "/site-packages"))))))
+ (add-after 'install 'move-docs
+ (lambda _
+ (mkdir-p (string-append #$output:doc "/share"))
+ (rename-file
+ (string-append #$output "/share/gtk-doc")
+ (string-append #$output:doc "/share/gtk-doc")))))))
(native-inputs
(list `(,glib "bin")
+ gtk-doc/stable
+ libxslt
pkg-config
python
python-argparse-manpage