summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-14 00:46:30 +0200
committerMarius Bakke <marius@gnu.org>2020-10-14 00:54:17 +0200
commit58af4c9621af02cc4e2bb5692d4b377084b0fcc6 (patch)
treea28127fce93f0eb20fe5100861329de7509556b3 /gnu/packages
parentfd595f31e3301df7976951ceb9683e66f629c3dd (diff)
Revert "gnu: python-chardet: Enable tests."
This causes too many rebuilds for the master branch. This reverts commit 331aaf52806b27430c4efaf8f230097ede69e61a.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/python-chardet-3.0.4-pytest.patch15
-rw-r--r--gnu/packages/python-xyz.scm5
2 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/patches/python-chardet-3.0.4-pytest.patch b/gnu/packages/patches/python-chardet-3.0.4-pytest.patch
deleted file mode 100644
index d5bf7ccc28..0000000000
--- a/gnu/packages/patches/python-chardet-3.0.4-pytest.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Fix test failure with Pytest 4.
-
-Taken from upstream:
-https://github.com/chardet/chardet/commit/440828f8faafdb58700c64a9ea8f6a30b154c08b
-
-diff --git a/test.py b/test.py
---- a/test.py
-+++ b/test.py
-@@ -59,5 +59,5 @@ def gen_test_params():
- full_path = join(path, file_name)
- test_case = full_path, encoding
- if full_path in EXPECTED_FAILURES:
-- test_case = pytest.mark.xfail(test_case)
-+ test_case = pytest.param(*test_case, marks=pytest.mark.xfail)
- yield test_case
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 10fa9b54b4..47ad101e4d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10060,13 +10060,14 @@ simulation, statistical modeling, machine learning and much more.")
(uri (pypi-uri "chardet" version))
(sha256
(base32
- "1bpalpia6r5x1kknbk11p1fzph56fmmnp405ds8icksd3knr5aw4"))
- (patches (search-patches "python-chardet-3.0.4-pytest.patch"))))
+ "1bpalpia6r5x1kknbk11p1fzph56fmmnp405ds8icksd3knr5aw4"))))
(native-inputs
`(("python-hypothesis" ,python-hypothesis)
("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)))
(build-system python-build-system)
+ ;; XXX: Incompatible with Pytest 4: <https://github.com/chardet/chardet/issues/173>.
+ (arguments `(#:tests? #f))
(home-page "https://github.com/chardet/chardet")
(synopsis "Universal encoding detector for Python 2 and 3")
(description