summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-05-02 21:59:30 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-04 13:08:59 +0200
commit59640af1c5348bde628157d265c81f5f9a9bf19f (patch)
tree65c88d293519a7663c726b1677028272350f2d3b /gnu/packages
parentfc6c96c88a0e4ad0b9e48272e5f97ffaa6eec36e (diff)
gnu: dune-common: Skip tests that fail on aarch64-linux.
* gnu/packages/patches/dune-common-skip-failing-tests.patch: New file. * gnu/packages/maths.scm (dune-common)[source]: Add it * gnu/local.mk (dist_patch_DATA): Register it. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm3
-rw-r--r--gnu/packages/patches/dune-common-skip-failing-tests.patch28
2 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d7e2719b70..1cf26927fa 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6805,7 +6805,8 @@ linear algebra primitives specifically targeting graph analytics.")
version "/dune-common-" version ".tar.gz"))
(sha256
(base32
- "04pzk8q0bibci8z5xlwndhh3y3vs63mw7kad62lbzfwrr5121hrd"))))
+ "04pzk8q0bibci8z5xlwndhh3y3vs63mw7kad62lbzfwrr5121hrd"))
+ (patches (search-patches "dune-common-skip-failing-tests.patch"))))
(build-system cmake-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/patches/dune-common-skip-failing-tests.patch b/gnu/packages/patches/dune-common-skip-failing-tests.patch
new file mode 100644
index 0000000000..7b0aa49d73
--- /dev/null
+++ b/gnu/packages/patches/dune-common-skip-failing-tests.patch
@@ -0,0 +1,28 @@
+Disable tests known to fail on AArch64:
+
+ https://gitlab.dune-project.org/core/dune-common/-/issues/262
+ https://issues.guix.gnu.org/62842
+
+--- a/dune/common/test/eigenvaluestest.cc
++++ b/dune/common/test/eigenvaluestest.cc
+@@ -340,20 +340,15 @@
+ testSymmetricFieldMatrix<double,200>();
+ testSymmetricFieldMatrix<float,4>();
+ testSymmetricFieldMatrix<float,200>();
+- testSymmetricFieldMatrix<long double,4>();
+- testSymmetricFieldMatrix<long double,200>();
+ #endif // HAVE_LAPACK
+
+ testSymmetricFieldMatrix<double,2>();
+ testSymmetricFieldMatrix<double,3>();
+ testSymmetricFieldMatrix<float,2>();
+ testSymmetricFieldMatrix<float,3>();
+- testSymmetricFieldMatrix<long double,2>();
+- testSymmetricFieldMatrix<long double,3>();
+
+ checkMultiplicity<double>();
+ checkMultiplicity<float>();
+- checkMultiplicity<long double>();
+
+ return 0;
+ }