summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:38:19 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit5c86352adaa422453b7c67e5a0cc5abe68b1d088 (patch)
treed63efc7594222a3d8123ee37e894932dec1eaf38 /gnu/packages
parentf90b81a5f08219592b863dfb6e769a9ce9496dc6 (diff)
gnu: kde-frameworks: Add kcodecs.
* gnu/packages/kde-frameworks.scm (kcodecs): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index d11d9f18cc..3fcd5141bc 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -246,6 +246,41 @@ GZip format, via a subclass of QIODevice.")
(license (list license:lgpl2.1 license:lgpl2.1+
license:lgpl3+ license:bsd-2))))
+(define-public kcodecs
+ (package
+ (name "kcodecs")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1qpzjh3qc2zz80j2bmlinipbispms14k9bmqw8v61zhi6in9z14c"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "String encoding and manipulating library")
+ (description "KCodecs provide a collection of methods to manipulate
+strings using various encodings.
+
+It can automatically determine the charset of a string, translate XML
+entities, validate email addresses, and find encodings by name in a more
+tolerant way than QTextCodec (useful e.g. for data coming from the
+Internet).")
+ ;; The included licenses is are gpl2 and lgpl2.1, but the sources are
+ ;; under a variety of licenses.
+ ;; This list is taken from http://packaging.neon.kde.org/cgit/
+ (license (list license:gpl2 license:gpl2+ license:bsd-2
+ license:lgpl2.1 license:lgpl2.1+ license:expat
+ license:lgpl3+ license:mpl1.1))))
+
(define-public kwindowsystem
(package
(name "kwindowsystem")