summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-01 17:49:45 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-01 17:51:17 +0800
commit6522f93ed098fa13f51f6d017035607e26237d31 (patch)
tree462872860ada8c9d852a93e8e5aa98fbdfcd261b /gnu/packages
parentba6460900f052759fe82e4ceb606d25e19f02884 (diff)
gnu: openssh: Update to 9.8p1 [security fixes].
Fixes a critical security bug allowing remote code execution as root: https://www.openssh.com/txt/release-9.8 This may be CVE-2024-6387 (currently embargoed): https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2024-6387 * gnu/packages/ssh.scm (openssh): Update to 9.8p1. Change-Id: I32e1001ca4d7f9bfbdad58ddcba58670e151a8cb
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ssh.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index ff39aea9ba..f4c80347a1 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -198,7 +199,7 @@ a server that supports the SSH-2 protocol.")
(define-public openssh
(package
(name "openssh")
- (version "9.7p1")
+ (version "9.8p1")
(source
(origin
(method url-fetch)
@@ -206,7 +207,7 @@ a server that supports the SSH-2 protocol.")
"openssh-" version ".tar.gz"))
(patches (search-patches "openssh-trust-guix-store-directory.patch"))
(sha256
- (base32 "1z9zfw7ndibxwprazlkv1isrh1yplczdin5cziijfanqcvvjc129"))))
+ (base32 "1wrrb8zrfj9wa9nbpx310kl2k05gm4gxsl5hvycx9dbrlc1d12yx"))))
(build-system gnu-build-system)
(arguments
(list