summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 12:15:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:12 +0200
commit657d220d172639e38bae65dba845f308daad6932 (patch)
tree19dafa69d4f88c167c79c56b4e4827027ac4e540 /gnu/packages
parentea6ffd3cea1780259c84f9df1b6aa24ea9f13728 (diff)
gnu: Add ghc-intervalmap.
* gnu/packages/haskell.scm (ghc-intervalmap): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index fcd6f50720..d986ab534b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9915,4 +9915,27 @@ programmers. It is written in pure Haskell and thus should be extremely
portable and easy to use.")
(license license:bsd-3)))
+(define-public ghc-intervalmap
+ (package
+ (name "ghc-intervalmap")
+ (version "0.6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/IntervalMap/"
+ "IntervalMap-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06hin9wf1by8aqa7820fsi2339bh82184frkwz3jsb9sqa0hszcg"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "http://www.chr-breitkopf.de/comp/IntervalMap")
+ (synopsis "Containers for intervals, with efficient search")
+ (description
+ "This package provides ordered containers of intervals, with efficient
+search for all keys containing a point or overlapping an interval. See the
+example code on the home page for a quick introduction.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here