summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-11-07 18:50:57 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-11-08 09:16:28 +0100
commit6ec0c6c7678234ff5ab4c892903e0b682cbd876d (patch)
tree4b207fd23f6b02563a82c37abc6e36783acf45e4 /gnu/packages
parent9371cf2138711ea7305951d82c5cf0b36ac4d6f1 (diff)
gnu: Add cl-alloy.
* gnu/packages/lisp-xyz.scm (sbcl-alloy, cl-alloy, ecl-alloy): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 53911487ac..778b48995d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17575,6 +17575,44 @@ fit together as required by any particular game.")
(define-public cl-trial
(sbcl-package->cl-source-package sbcl-trial))
+(define-public sbcl-alloy
+ (let ((commit "e86e22c2887836ec31cd97e039f0bca5248d8f1c")
+ (revision "1"))
+ (package
+ (name "sbcl-alloy")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shirakumo/alloy")
+ (commit commit)))
+ (file-name (git-file-name "alloy" version))
+ (sha256
+ (base32 "1jsqjr6sf86hcdvnjp4gd10qv0r7kfkr9hmda85irb5lha4q9n7w"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("parachute" ,sbcl-parachute)))
+ (inputs
+ `(("array-utils" ,sbcl-array-utils)
+ ("closer-mop" ,sbcl-closer-mop)
+ ("documentation-utils" ,sbcl-documentation-utils)))
+ (home-page "https://shirakumo.github.io/alloy/")
+ (synopsis
+ "Common Lisp user interface protocol and toolkit implementation")
+ (description
+ "Alloy is a user interface toolkit. It is defined through a set of
+protocols that allow for a clear interface, as well as a standardised way to
+integrate Alloy into a target backend.")
+ (license license:zlib))))
+
+(define-public ecl-alloy
+ (sbcl-package->ecl-package sbcl-alloy))
+
+(define-public cl-alloy
+ (sbcl-package->cl-source-package sbcl-alloy))
+
(define-public sbcl-org-sampler
(let ((commit "ee135a417750e5b1d810bb9574eb85223cb3038a")
(revision "1"))