summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-09-19 19:30:33 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-09-22 07:33:56 +0200
commit728d5b6b0684727e8f1611d3e0f9cc293dd395d2 (patch)
treee4c7a43fe2b1e60793e71ae92fa0b223cdb689f4 /gnu/packages
parent33d4992b69bfed2ec6b15b7b842599efb1cb1e31 (diff)
gnu: Add ocaml-lablgtk3-sourceview3.
* gnu/packages/ocaml.scm (ocaml-lablgtk3-sourceview3): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b94c565ba6..a995ffe08a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8040,6 +8040,19 @@ generate OCaml code from .glade files), libpanel, librsvg and quartz.")
;; Version 2 only, with linking exception.
(license license:lgpl2.0)))
+(define-public ocaml-lablgtk3-sourceview3
+ (package
+ (inherit lablgtk3)
+ (name "ocaml-lablgtk3-sourceview3")
+ (propagated-inputs (list lablgtk3))
+ (native-inputs (list gtksourceview-3 pkg-config))
+ (arguments
+ `(#:package "lablgtk3-sourceview3"
+ #:test-target "."))
+ (synopsis "OCaml interface to GTK+ gtksourceview library")
+ (description "This package provides the lablgtk interface to the
+GTK+ gtksourceview library.")))
+
(define-public ocaml-reactivedata
(package
(name "ocaml-reactivedata")