summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-08 11:06:42 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-15 12:15:08 +0200
commit77480fb19212e7c323e2506c5bb3e1bfe21ead15 (patch)
tree09e6e9c40db2f247f05de5faacfa7fcbbc9cf244 /gnu/packages
parentc39470b115a3f0b63ec28b0895553b7facb88241 (diff)
gnu: util-linux: Disable unreliable ioctl_ns test on IA-32.
* gnu/packages/linux.scm (util-linux)[arguments]<#:phases>{delete-lsns-test}: New phase. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index cd3e46504a..bb57466dfe 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2021 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1804,6 +1805,16 @@ providing the system administrator with some help in common tasks.")
(string-append
all "\n"
"ts_skip \"setarch tests are unreliable under QEMU\"")))))
+ ,@(if (target-x86-32?)
+ `((add-before 'check 'disable-lsns-test
+ (lambda _
+ ;; The lsns tests can fail due to ioctl(_, NS_GET_USERNS)
+ ;; returning ENOTTY, indicating this kernel does not
+ ;; support user namespaces. Curiously, this test can fail
+ ;; on i686 even if the same test passes on x86_64 on the
+ ;; same machine. See <https://issues.guix.gnu.org/49933>.
+ (delete-file "tests/ts/lsns/ioctl_ns"))))
+ '())
(add-after 'install 'move-static-libraries
(lambda* (#:key outputs #:allow-other-keys)
(let ((lib (assoc-ref outputs "lib"))