summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 15:07:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:56 +0200
commit79b6fa0e01f0c2f990854d7f000e30f73fd0fbaa (patch)
treee8080e1fe21752cd7d068a7f5e388d592f28dd33 /gnu/packages
parent55d48b8bb88e4f6973e1fa993fc4739edfe64897 (diff)
gnu: rust-curve25519-dalek: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-curve25519-dalek-3, rust-curve25519-dalek-ng-4): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: I1c762d754e54a7736278e850fbc81488bdcebc92
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-crypto.scm68
-rw-r--r--gnu/packages/crates-io.scm68
2 files changed, 68 insertions, 68 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 7ad9e2fcc0..da9021744f 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1116,3 +1116,71 @@ algorithms.")
(description "This package provides a wrapper for OS-level cryptographic
hash functions.")
(license license:expat)))
+
+(define-public rust-curve25519-dalek-3
+ (package
+ (name "rust-curve25519-dalek")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "curve25519-dalek" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0q8v97275cy6v4ly6y2qwv9a8phnpjg9sy8kv7r6mgdjfacxz7qb"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-digest" ,rust-digest-0.9)
+ ("rust-fiat-crypto" ,rust-fiat-crypto-0.1)
+ ("rust-packed-simd-2" ,rust-packed-simd-2-0.3)
+ ("rust-rand-core" ,rust-rand-core-0.5)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-subtle" ,rust-subtle-2)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-bincode" ,rust-bincode-1)
+ ("rust-criterion" ,rust-criterion-0.3)
+ ("rust-hex" ,rust-hex-0.4)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-sha2" ,rust-sha2-0.9))))
+ (home-page "https://dalek.rs/curve25519-dalek")
+ (synopsis "Group operations on ristretto255 and Curve25519")
+ (description
+ "This package provides a pure-Rust implementation of group operations on
+ristretto255 and Curve25519.")
+ (license license:bsd-3)))
+
+(define-public rust-curve25519-dalek-ng-4
+ (package
+ (name "rust-curve25519-dalek-ng")
+ (version "4.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "curve25519-dalek-ng" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1j6y6dsqdfp26ifyygibsrm1a8f9f7870i4053xlczil95r9nd8w"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-digest" ,rust-digest-0.9)
+ ("rust-packed-simd-2" ,rust-packed-simd-2-0.3)
+ ("rust-rand-core" ,rust-rand-core-0.6)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-subtle-ng" ,rust-subtle-ng-2)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-bincode" ,rust-bincode-1)
+ ("rust-criterion" ,rust-criterion-0.3)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-sha2" ,rust-sha2-0.9))))
+ (home-page "https://github.com/zkcrypto/curve25519-dalek-ng")
+ (synopsis "Implementation of group operations on ristretto255 and Curve25519")
+ (description
+ "This package provides a pure-Rust implementation of group operations on
+ristretto255 and Curve25519.")
+ (license license:bsd-3)))
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ea1bac6913..66802cb56e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17022,74 +17022,6 @@ requests.")
"This package provides native bindings to the @code{libcurl} library.")
(license license:expat)))
-(define-public rust-curve25519-dalek-3
- (package
- (name "rust-curve25519-dalek")
- (version "3.2.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "curve25519-dalek" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0q8v97275cy6v4ly6y2qwv9a8phnpjg9sy8kv7r6mgdjfacxz7qb"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-byteorder" ,rust-byteorder-1)
- ("rust-digest" ,rust-digest-0.9)
- ("rust-fiat-crypto" ,rust-fiat-crypto-0.1)
- ("rust-packed-simd-2" ,rust-packed-simd-2-0.3)
- ("rust-rand-core" ,rust-rand-core-0.5)
- ("rust-serde" ,rust-serde-1)
- ("rust-subtle" ,rust-subtle-2)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs
- (("rust-bincode" ,rust-bincode-1)
- ("rust-criterion" ,rust-criterion-0.3)
- ("rust-hex" ,rust-hex-0.4)
- ("rust-rand" ,rust-rand-0.7)
- ("rust-sha2" ,rust-sha2-0.9))))
- (home-page "https://dalek.rs/curve25519-dalek")
- (synopsis "Group operations on ristretto255 and Curve25519")
- (description
- "This package provides a pure-Rust implementation of group operations on
-ristretto255 and Curve25519.")
- (license license:bsd-3)))
-
-(define-public rust-curve25519-dalek-ng-4
- (package
- (name "rust-curve25519-dalek-ng")
- (version "4.1.1")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "curve25519-dalek-ng" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1j6y6dsqdfp26ifyygibsrm1a8f9f7870i4053xlczil95r9nd8w"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-byteorder" ,rust-byteorder-1)
- ("rust-digest" ,rust-digest-0.9)
- ("rust-packed-simd-2" ,rust-packed-simd-2-0.3)
- ("rust-rand-core" ,rust-rand-core-0.6)
- ("rust-serde" ,rust-serde-1)
- ("rust-subtle-ng" ,rust-subtle-ng-2)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs
- (("rust-bincode" ,rust-bincode-1)
- ("rust-criterion" ,rust-criterion-0.3)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-sha2" ,rust-sha2-0.9))))
- (home-page "https://github.com/zkcrypto/curve25519-dalek-ng")
- (synopsis "Implementation of group operations on ristretto255 and Curve25519")
- (description
- "This package provides a pure-Rust implementation of group operations on
-ristretto255 and Curve25519.")
- (license license:bsd-3)))
-
(define-public rust-cust-0.2
(package
(name "rust-cust")