summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:17:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:37 +0200
commit7dcb4e9e15b6459e25bc25545371219491536255 (patch)
tree17e1a2bdd07b7c06caea8c6539b7734cf44bcbe3 /gnu/packages
parentdd53cac90eeea23df5829ff8260103941a9573d7 (diff)
gnu: Add texlive-stricttex.
* gnu/packages/tex.scm (texlive-stricttex): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6554ee9e30..756cbe02bd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13955,6 +13955,27 @@ By default the @code{preview} package is used to display the typeset code
without margins.")
(license license:lppl1.3+)))
+(define-public texlive-stricttex
+ (package
+ (name "texlive-stricttex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/stricttex/"
+ "tex/lualatex/stricttex/")
+ (base32
+ "1ddlcwj1bnj6zrkljkz3jywgri34f4g9gshbwd0lzz4nz03v82rv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/stricttex")
+ (synopsis "Strictly balanced brackets and numbers in command names")
+ (description
+ "This is a small, LuaLaTeX-only package providing you with three,
+sometimes useful features. It allows you to make brackets @samp{[...]}
+strict, meaning that each @samp{[} must be balanced by a @samp{]}. It also
+allows you to use numbers and primes in command names.")
+ (license license:lppl1.3c)))
+
(define-public texlive-siunitx
(package
(name "texlive-siunitx")