summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-07-31 10:42:47 +0800
committer宋文武 <iyzsong@gmail.com>2016-07-31 10:42:47 +0800
commit85860fdf82f75c2026d8b93aac14ad34feea3d87 (patch)
tree6d21575a043267d25d2588f0f72ae3120ab0e43c /gnu/packages
parentc2c54ebd9153fd4a9609a3c58fb689aa9b242640 (diff)
gnu: glibc-locales: Fix build.
* gnu/packages/patches/glibc-locales.patch: Adjust to glibc-2.23. * gnu/packages/base.scm (glibc-locales)[arguments]: Pass 'lib_cv_complocaledir'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/base.scm2
-rw-r--r--gnu/packages/patches/glibc-locales.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 3135108ac8..5edf3eb493 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -786,7 +786,7 @@ the 'share/locale' sub-directory of this package.")
((#:configure-flags flags)
`(append ,flags
;; Use $(libdir)/locale/X.Y as is the case by default.
- (list (string-append "libc_cv_localedir="
+ (list (string-append "libc_cv_complocaledir="
(assoc-ref %outputs "out")
"/lib/locale/"
,(package-version glibc))))))))))
diff --git a/gnu/packages/patches/glibc-locales.patch b/gnu/packages/patches/glibc-locales.patch
index 1bcf12bf6f..3a125e845e 100644
--- a/gnu/packages/patches/glibc-locales.patch
+++ b/gnu/packages/patches/glibc-locales.patch
@@ -5,8 +5,8 @@ in a package separate from glibc.
2. Use '--no-archive' to avoid building the big locale archive, and
because the already-built 'localedef' would want to write it
to '/run/current-system/locale', which is not possible.
- 3. Pass $(localedir)/$$locale to install files in the right place, and
- because otherwise, 'localedef' fails with:
+ 3. Pass $(inst_complocaledir)/$$locale to install files in the right
+ place, and because otherwise, 'localedef' fails with:
"cannot write output files to `(null)'".
--- glibc-2.22/localedata/Makefile 1970-01-01 01:00:00.000000000 +0100
@@ -25,7 +25,7 @@ in a package separate from glibc.
$(LOCALEDEF) --alias-file=../intl/locale.alias \
-i locales/$$input -c -f charmaps/$$charset \
- $(addprefix --prefix=,$(install_root)) $$locale \
-+ $(addprefix --prefix=,$(install_root)) $(localedir)/$$locale \
++ $(addprefix --prefix=,$(install_root)) $(inst_complocaledir)/$$locale \
&& echo ' done'; \
tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP