summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-04 07:11:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-04 07:27:43 +0200
commit8a3766e1d37bf8aa411a19e29d57c4e0fb6fc30d (patch)
treea689b2dce9ffe2a4fe1b5a4205412420239ee33d /gnu/packages
parentaa9a94bba9a5705c6a4bfb19268dc616b7f4f7d3 (diff)
gnu: Add r-conflicted.
* gnu/packages/cran.scm (r-conflicted): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d5b71d65d3..679387e473 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26163,6 +26163,33 @@ expressive statistical grammar that coheres with the Tidy design framework.")
model-related packages.")
(license license:expat)))
+(define-public r-conflicted
+ (package
+ (name "r-conflicted")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "conflicted" version))
+ (sha256
+ (base32
+ "0xp04cdvmp3b1phazhmjqn0vmax1b2218xsb5854ffv43m7qvrra"))))
+ (properties `((upstream-name . "conflicted")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-memoise" ,r-memoise)
+ ("r-rlang" ,r-rlang)))
+ (home-page "https://github.com/r-lib/conflicted")
+ (synopsis "Alternative conflict resolution strategy")
+ (description
+ "R's default conflict management system gives the most recently loaded
+package precedence. This can make it hard to detect conflicts, particularly
+when they arise because a package update creates ambiguity that did not
+previously exist. The @code{conflicted} package takes a different approach,
+making every conflict an error and forcing you to choose which function to
+use.")
+ (license license:gpl3)))
+
(define-public r-tidymodels
(package
(name "r-tidymodels")