summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:45:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:18 +0200
commit8cb294628a161776be1e69af9189b85c6345992e (patch)
tree43fd7b43f17825f7af773f14c8ec0cf658bd0506 /gnu/packages
parent6bc9993d038a87549e9a8f8702260a4f2841aed9 (diff)
gnu: Add texlive-lua-ul.
* gnu/packages/tex.scm (texlive-lua-ul): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 74d84240ea..130cae2505 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16207,6 +16207,28 @@ sort text in a language dependent way, like indexing processors, bibliographic
generators, etc.")
(license license:expat)))
+(define-public texlive-lua-ul
+ (package
+ (name "texlive-lua-ul")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/lua-ul/"
+ "source/lualatex/lua-ul/"
+ "tex/lualatex/lua-ul/")
+ (base32
+ "0xpa41hkjzqcws7yjj6s8ys93qyhnv6zfv7479qbv58h5mgfxzhh")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/lua-ul")
+ (synopsis "Underlining for LuaLaTeX")
+ (description
+ "This package provides underlining, strikethough, and highlighting using
+features in LuaLaTeX which avoid the restrictions imposed by other methods.
+In particular, kerning is not affected, the underlined text can use arbitrary
+commands, hyphenation works etc.")
+ (license license:lppl1.3c)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")