summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:42:36 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit8cb7bab991100cf9e395130ad717f82815ffc902 (patch)
tree8b9bde9e98c358eb4d6b1041d7a447b34c2ad131 /gnu/packages
parent4f4afb63c7094b6b95ea19e2d84bf5342be1dabb (diff)
gnu: kde-frameworks: Add kidletime.
* gnu/packages/kde-frameworks.scm (kidletime): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 4d9d18eae8..ae2be05ca7 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -528,6 +528,33 @@ translated text. This includes argument capturing, customizable markup, and
translation scripting.")
(license license:lgpl2.1+)))
+(define-public kidletime
+ (package
+ (name "kidletime")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "09jsj0pj27h93nr8v46savs6b93h8frydinfr7wlijkvpsl02jb4"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Reporting of idle time of user and system")
+ (description "KIdleTime is a singleton reporting information on idle time.
+It is useful not only for finding out about the current idle time of the PC,
+but also for getting notified upon idle time events, such as custom timeouts,
+or user activity.")
+ (license (list license:gpl2+ license:lgpl2.1+))))
+
(define-public kwindowsystem
(package
(name "kwindowsystem")