summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-04 07:15:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-04 07:27:44 +0200
commit946f1608ae224ddbf3c699132ef9a313a1969f42 (patch)
treecbed45590cd02289a71017efee63be7af6599a2c /gnu/packages
parent4c2826df656e3c513fba140a0c82b763c93fc83b (diff)
gnu: Add r-googlesheets4.
* gnu/packages/cran.scm (r-googlesheets4): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9224a6d16d..02698384ec 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -230,6 +230,42 @@ visualization of their differences.")
pronounceable identifiers.")
(license license:expat)))
+(define-public r-googlesheets4
+ (package
+ (name "r-googlesheets4")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "googlesheets4" version))
+ (sha256
+ (base32
+ "04b17cdzah2r92qj7imrdlpfzyxwyf1vx8k1kvsr36nqg383f4b2"))))
+ (properties `((upstream-name . "googlesheets4")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cellranger" ,r-cellranger)
+ ("r-curl" ,r-curl)
+ ("r-gargle" ,r-gargle)
+ ("r-glue" ,r-glue)
+ ("r-googledrive" ,r-googledrive)
+ ("r-httr" ,r-httr)
+ ("r-ids" ,r-ids)
+ ("r-lifecycle" ,r-lifecycle)
+ ("r-magrittr" ,r-magrittr)
+ ("r-purrr" ,r-purrr)
+ ("r-rematch2" ,r-rematch2)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)
+ ("r-vctrs" ,r-vctrs)))
+ (home-page "https://github.com/tidyverse/googlesheets4")
+ (synopsis "Access Google Sheets using the Sheets API V4")
+ (description
+ "This package lets you interact with Google Sheets through the
+@url{https://developers.google.com/sheets/api,Sheets API v4}. This package
+can read and write both the metadata and the cell data in a Sheet.")
+ (license license:expat)))
+
(define-public r-waldo
(package
(name "r-waldo")