summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-06 13:11:43 -0500
committerMark H Weaver <mhw@netris.org>2015-01-06 13:30:17 -0500
commit97f94f5e9b610781e19ba9e7584ffe46d859de2e (patch)
tree545e20bbd5ea850dc0426d09092ae1a8a96a3468 /gnu/packages
parentcd06768e66b0e2babf792e46e5066bac89ecae81 (diff)
gnu: gtk+: Include xorg-server in native-inputs on MIPS; enable tests.
* gnu/packages/gtk.scm (gtk+)[native-inputs]: Unconditionally include xorg-server and enable tests.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index ce1c533df8..dae3bac567 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
@@ -418,18 +418,9 @@ application suites.")
("pkg-config" ,pkg-config)
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)
-
- ;; FIXME: The Xorg server is needed to run the tests, but it currently
- ;; fails to build on mips64el, so remove it in the meantime.
- ,@(if (string=? (or (%current-target-system) (%current-system))
- "mips64el-linux")
- '()
- `(("xorg-server" ,xorg-server)))))
+ ("xorg-server" ,xorg-server)))
(arguments
- `(;; FIXME: See above.
- #:tests? ,(not (string=? (or (%current-target-system) (%current-system))
- "mips64el-linux"))
- #:phases
+ `(#:phases
(alist-replace
'configure
(lambda* (#:key inputs #:allow-other-keys #:rest args)