summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-27 08:34:43 -0500
committerMark H Weaver <mhw@netris.org>2014-12-27 08:45:17 -0500
commit9a224ac2e37482cb69c2803648bf3c66fbc6eee9 (patch)
treeb66dc6b4526266342c4643d97a6589716669d0c9 /gnu/packages
parent6aa47e388390e98bec6caa90fef7f39a60e338a7 (diff)
gnu: Use patch --force instead of --batch.
* gnu/packages/linux.scm (linux-libre, net-tools): Pass "--force" to patch, instead of "--batch". * gnu/packages/mit-krb5.scm (mit-krb5): Ditto.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/packages/mit-krb5.scm2
2 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a2708a290f..9dc5f5cd40 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -196,7 +196,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
(build-phase
'(lambda* (#:key system inputs #:allow-other-keys #:rest args)
;; Apply the neat patch.
- (system* "patch" "-p1" "--batch"
+ (system* "patch" "-p1" "--force"
"-i" (assoc-ref inputs "patch/freedo+gnu"))
(let ((arch (car (string-split system #\-))))
@@ -774,7 +774,7 @@ manpages.")
'unpack 'patch
(lambda* (#:key inputs #:allow-other-keys)
(define (apply-patch file)
- (zero? (system* "patch" "-p1" "--batch"
+ (zero? (system* "patch" "-p1" "--force"
"--input" file)))
(let ((patch.gz (assoc-ref inputs "patch")))
diff --git a/gnu/packages/mit-krb5.scm b/gnu/packages/mit-krb5.scm
index 2528f46157..3f3e85773e 100644
--- a/gnu/packages/mit-krb5.scm
+++ b/gnu/packages/mit-krb5.scm
@@ -62,7 +62,7 @@
;; XXX The current patch system does not support unusual
;; source unpack methods, so we have to apply this patch in a
;; non-standard way.
- (zero? (system* "patch" "-p1" "--batch" "-i"
+ (zero? (system* "patch" "-p1" "--force" "-i"
(assoc-ref %build-inputs "patch/init-fix"))))))
(alist-replace
'check