summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRemco van 't Veer <remco@remworks.net>2024-05-14 18:01:26 +0200
committerAndreas Enge <andreas@enge.fr>2024-05-15 15:48:41 +0200
commit9d42741693c02396be54ccf548b4c36249e94ef2 (patch)
tree348338294a39af98b53aa654f6a37dd2b128bfeb /gnu/packages
parent8e5579f37c4de33b4ed160642577fe5a83ec5910 (diff)
gnu: krita: Fix build.
* gnu/packages/kde.scm (krita): Fix build. [source]: Apply krita-bump-sip-abi-version-to-12.8 patch. * gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I322c32716a676af7c90e019b53a1fd5395701b49 Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde.scm4
-rw-r--r--gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch25
2 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 51c4fc2751..6d02547c4e 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Mehmet Tekman <mtekman89@gmail.com>
+;;; Copyright © 2024 Remco van 't Veer <remco@remworks.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -726,7 +727,8 @@ painting, image manipulating and icon editing.")
"mirror://kde/stable/krita/" version "/krita-" version
".tar.gz"))
(sha256
- (base32 "1kzmn89b1vrasba7z8hp8izyrrskgc7ggnz82zqyyy1v5d8mnri7"))))
+ (base32 "1kzmn89b1vrasba7z8hp8izyrrskgc7ggnz82zqyyy1v5d8mnri7"))
+ (patches (search-patches "krita-bump-sip-abi-version-to-12.8.patch"))))
(build-system qt-build-system)
(arguments
`(#:tests? #f
diff --git a/gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch b/gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch
new file mode 100644
index 0000000000..02852e0f5a
--- /dev/null
+++ b/gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch
@@ -0,0 +1,25 @@
+From 2d71c47661d43a4e3c1ab0c27803de980bdf2bb2 Mon Sep 17 00:00:00 2001
+From: Antonio Rojas <arojas@archlinux.org>
+Date: Mon, 11 Dec 2023 20:26:13 +0100
+Subject: [PATCH] Bump SIP ABI version to 12.8
+
+Fixes build with SIP 6.8
+---
+ cmake/modules/pyproject.toml.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/modules/pyproject.toml.in b/cmake/modules/pyproject.toml.in
+index 090b2d4b0cb..085ddf41799 100644
+--- a/cmake/modules/pyproject.toml.in
++++ b/cmake/modules/pyproject.toml.in
+@@ -9,7 +9,7 @@ name = "@module_name_toml@"
+ sip-module = "@sip_name@"
+ sip-include-dirs = @sip_include_dirs@
+ sip-files-dir = "@module_srcs@"
+-abi-version = "12"
++abi-version = "12.8"
+
+ [tool.sip.bindings.@module_name_toml@]
+ tags = @module_tags@
+--
+GitLab