summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-06-11 23:06:57 +0200
committerLudovic Courtès <ludo@gnu.org>2024-06-11 23:09:08 +0200
commita24e8de6cea9cc413eb1de5c0cc9584299a96355 (patch)
tree40430f11fa7e7a3b949c7e750b30ea41b37cc903 /gnu/packages
parent865bf63eb3025b978a74805ef0ea8325c97d88e9 (diff)
gnu: libressl: Run tests under ‘datefudge’.
Fixes <https://issues.guix.gnu.org/71491>. * gnu/packages/tls.scm (libressl)[arguments]: Add #:phases. Change-Id: I85d866808a01265c90de6c662f35a083773faf08
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tls.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 719da8e113..760b917768 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2017, 2019-2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2017, 2019-2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2021 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
@@ -701,7 +701,19 @@ kilobytes of RAM.")
"/share/libressl-"
,(package-version this-package))
;; Provide a TLS-enabled netcat.
- "--enable-nc")))
+ "--enable-nc")
+
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; 'tests/tlstest.sh' started failing in 2024 due to
+ ;; an expired test certificate.
+ (invoke "datefudge" "2020-01-01"
+ "make" "check"
+ "-j" (number->string
+ (parallel-job-count)))))))))
+ (native-inputs (list datefudge))
(properties
`((release-monitoring-url . "https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/")))
(home-page "https://www.libressl.org/")