summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-08 18:18:44 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:53 +0200
commita2db33124a0672e9b9187bb862a556afb6450c77 (patch)
treece319f2ec0df313df1887f97702de8fab7c4e19e /gnu/packages
parentee4557f15e0fbe45a3951f45f0a898a55e2f2037 (diff)
gnu: Add rust-cachedir-0.3.
* gnu/packages/crates-io.scm (rust-cachedir-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 10f55f372f..2a77e5393f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9756,6 +9756,30 @@ CachePadded to ensure updating one piece of data doesn't invalidate other
cached data.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-cachedir-0.3
+ (package
+ (name "rust-cachedir")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cachedir" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0wyqx30crm2qsq4ny57hhljyq6iw6j4qfg7fbfiqznvpf29z60s7"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-tempfile" ,rust-tempfile-3))))
+ (home-page "https://github.com/jstasiak/cachedir")
+ (synopsis "Interact with cache directories and @file{CACHEDIR.TAG} files")
+ (description
+ "This package provides a library to help interacting with cache
+directories and @file{CACHEDIR.TAG} files as defined by the Cache Directory
+Tagging Specification. This library comes with functionality to, among
+others, add a tag, ensure/check a tag exists and get the state of a tag.")
+ (license license:expat)))
+
(define-public rust-calamine-0.18
(package
(name "rust-calamine")