summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-06-22 19:54:26 +0900
committerLudovic Courtès <ludo@gnu.org>2023-10-12 18:53:07 +0200
commita798477db811d428bfcf91dacb12687dae0d141c (patch)
treef29ce7c8d08fd3f1d8fe46c64e6c0b6b3c847b57 /gnu/packages
parentcf111ec0bae4bd0a48fa737de1d0bc5ed4d15da2 (diff)
gnu: Add go-github-com-delthas-go-localeinfo.
gnu/packages/golang.scm (go-github-com-delthas-go-localeinfo): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 251eba438a..0277265375 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10658,6 +10658,29 @@ extracting information about the music/image/video that is Now Playing on the
system.")
(license license:expat))))
+(define-public go-github-com-delthas-go-localeinfo
+ (let ((commit "686a1e18511819b2f1625f00437f6e1246c04a5d"))
+ (package
+ (name "go-github-com-delthas-go-localeinfo")
+ (version (git-version "0.0.0" "0" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/delthas/go-localeinfo")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0r0v42ggvyss8327nggwinxl42pj4l0dwz96g9wk1w8h8vmfrh0z"))))
+ (build-system go-build-system)
+ (arguments `(#:tests? #f ; FIXME: tests assume certain locale
+ #:import-path "github.com/delthas/go-localeinfo"))
+ (home-page "https://github.com/delthas/go-localeinfo")
+ (synopsis "Library for extracting locale information")
+ (description "@code{go-localeinfo} extracts monetary/numeric/time
+formatting information, rather than the current locale name.")
+ (license license:expat))))
+
(define-public go-github-com-prometheus-common
(package
(name "go-github-com-prometheus-common")