summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-29 01:06:53 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-29 01:08:17 +0200
commita8b705252bdcb642999258859ada1c2f43706092 (patch)
tree71fea7ce6a58a02ae0e1678a5b820c5b372da79b /gnu/packages
parent05528dcd4827ef449e2014794ab74085e57651b9 (diff)
gnu: Add i7z.
* gnu/packages/hardware.scm (i7z): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/hardware.scm47
-rw-r--r--gnu/packages/radio.scm15
-rw-r--r--gnu/packages/shells.scm5
3 files changed, 61 insertions, 6 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index ecbcca79b1..e7dd4a1fa7 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -137,6 +137,53 @@ calibrated, and restored when the calibration is applied.")
human-readable format and checks if it conforms to the standards.")
(license license:expat))))
+(define-public i7z
+ (let ((revision "0")
+ (commit "1a41ff13db747e962456ddbb5ccb2b7fc43ca0cb"))
+ (package
+ (name "i7z")
+ (version (git-version "0.28" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/afontenot/i7z")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jxm63a8y1mfl1sa4mzzfs3bgnym6achj1yc0jglmp05xal16lm1"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (for-each delete-file-recursively
+ (list "src/GUI"
+ "src/perfmon-i7z"
+ "scripts"))))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target)))
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (home-page "https://github.com/afontenot/i7z")
+ (synopsis "Thermal and C-state reporting on older Intel Core CPUs")
+ (description
+ "The @command{i7z} utility accurately measures the current frequency
+and temperature of older Intel Core (i3, i5, and i7) processors including the
+Nehalem, Sandy Bridge, and Ivy Bridge generations. Reliable support for newer
+CPUs is not guaranteed, as this package has not seen significant development
+since 2013.
+
+If your processor is supported, you'll get detailed reports on Turbo Boost and
+clock multipliers, core voltage, and time spent in different C-states. This
+information can be viewed in real time and/or logged to a file.")
+ (license license:gpl2))))
+
(define-public libsmbios
(package
(name "libsmbios")
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 991d2e3a2e..b00b33ca38 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -481,11 +481,13 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
(version "3.9.0.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.gnuradio.org/releases/gnuradio/"
- "gnuradio-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnuradio/gnuradio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1jvm9xd0l2pz1fww4zii6hl7ccnvy256nrf70ljb594n7j9j49ha"))))
+ (base32 "1fbl8lslzrkx7lpkibhvs6gvhqnn8yrrq3n6irybfnifh2536d36"))))
(build-system cmake-build-system)
(native-inputs
`(("doxygen" ,doxygen)
@@ -550,6 +552,11 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
"/share/javascript/mathjax"))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-source-writable
+ (lambda _
+ ;; The test_add and test_newmod open(sources, "w") for some reason.
+ (for-each make-file-writable
+ (find-files "." ".*"))))
(add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(let ((qwt (assoc-ref inputs "qwt")))
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index f080d71c40..f1c13dc1bd 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -945,7 +945,7 @@ files and text.")
(define-public nushell
(package
(name "nushell")
- (version "0.32.0")
+ (version "0.33.0")
(source
(origin
(method git-fetch)
@@ -954,7 +954,7 @@ files and text.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1wj054rzv88ys4ask4zp7crrw0dxrck8svlj3i16qqd8x5dnyhqs"))))
+ (base32 "0rdvvg6hf01bljq0zz0c66kbzy5ggbcbil1j45hklzq0ibffdj02"))))
(build-system cargo-build-system)
(arguments
`(#:rust ,rust-1.47
@@ -995,6 +995,7 @@ files and text.")
("rust-nu-plugin-to-sqlite" ,rust-nu-plugin-to-sqlite-0.32)
("rust-nu-plugin-tree" ,rust-nu-plugin-tree-0.32)
("rust-nu-plugin-xpath" ,rust-nu-plugin-xpath-0.32)
+ ("rust-polars-0.13" ,rust-polars-0.13)
("rust-pretty-env-logger" ,rust-pretty-env-logger-0.4))
#:cargo-development-inputs
(("rust-dunce" ,rust-dunce-1)