summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-15 20:46:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-16 02:03:24 +0200
commitad8cdc7b89d8f2d4406c70d3833f77f2f4cb20e4 (patch)
tree1861b2cceda117b789ccfaf3be72839006b7d0a5 /gnu/packages
parent7f4a81540acb58edf740841addcbe07bf3b1f904 (diff)
gnu: swaks: Use git source.
* gnu/packages/mail.scm (swaks)[source]: Use GIT-FETCH and GIT-FILE-NAME. [argument]: Add a ‘set-build_version’ phase. Adjust the POD file name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 87e45fa988..e49a8bdae1 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3233,13 +3233,13 @@ on the fly. Both programs are written in C and are very fast.")
(version "20190914.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://jetmore.org/john/code/swaks/files/swaks-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jetmore/swaks")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "12awq5z4sdd54cxprj834zajxhkpy4jwhzf1fhigcx1zbhdaacsp"))))
+ (base32 "0xd3952mm8r0nj32rhvciiaq8cx4hxvr7nqpv4njq18q6gv13qby"))))
(build-system perl-build-system)
(inputs
`(("perl-io-socket-inet6" ,perl-io-socket-inet6)
@@ -3250,10 +3250,15 @@ on the fly. Both programs are written in C and are very fast.")
`(#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'set-build_version
+ (lambda _
+ (substitute* "swaks"
+ (("\"DEVRELEASE\"") (format #f "\"~a\"" ,version)))
+ #true))
(delete 'configure)
(replace 'build
(lambda _
- (invoke "pod2man" "doc/ref.pod" "swaks.1")))
+ (invoke "pod2man" "doc/base.pod" "swaks.1")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))