summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-20 16:11:14 +0200
committerMarius Bakke <marius@gnu.org>2021-07-23 17:26:43 +0200
commitb51bb5bcdc93b4bf41bdbfa8be956a87613ddb3e (patch)
treee1e1f7ac5518c32c56af4066d0556227efed9f68 /gnu/packages
parentf94a0ce61ff89ad69c1ea327bb4ea763f0d5b2c0 (diff)
gnu: gsl: Update to 2.7.
* gnu/packages/maths.scm (gsl): Update to 2.7. [arguments]: Remove trailing #t's.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7f504fa52b..1726adedb8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -479,14 +479,14 @@ precision floating point numbers.")
(define-public gsl
(package
(name "gsl")
- (version "2.6")
+ (version "2.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gsl/gsl-"
version ".tar.gz"))
(sha256
(base32
- "1a460zj9xmbgvcymkdhqh313c4l29mn9cffbi5vf33x3qygk70mp"))))
+ "0av04cpblphvvs3kl5rwphniarml503501vrpqw31rd0bmwg7fzg"))))
(build-system gnu-build-system)
(arguments
(let ((system (%current-system)))
@@ -501,8 +501,7 @@ precision floating point numbers.")
'((add-before 'check 'disable-failing-tests
(lambda _
(substitute* "spmatrix/test.c"
- ((".*test_complex.*") "\n"))
- #t))))
+ ((".*test_complex.*") "\n"))))))
((string-prefix? "i686" system)
;; There are rounding issues with these tests on i686:
@@ -518,8 +517,7 @@ precision floating point numbers.")
(substitute* "spmatrix/test.c"
((".*test_all.*") "\n")
((".*test_float.*") "\n")
- ((".*test_complex.*") "\n"))
- #t))))
+ ((".*test_complex.*") "\n"))))))
(else '()))))))
(home-page "https://www.gnu.org/software/gsl/")