summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2024-05-15 13:29:03 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2024-05-15 16:02:51 +0300
commitb53fac227836bcec3a2a7a44f7720b9a23db90f2 (patch)
tree800d588b3321778989b5ebd55007141917caf7c4 /gnu/packages
parentbe60d20005f788a9c109a7943d5f4976f4c4045c (diff)
gnu: Add obs-source-record.
* gnu/packages/video.scm (obs-source-record): New variable. Change-Id: I23792f9cbc90f922376f880c4dda9b5e1f99f9e3
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/video.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 938dca295d..2e7ba6d10e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4156,6 +4156,35 @@ your host privately.")
inputs and applications using PipeWire.")
(license license:gpl2+)))
+(define-public obs-source-record
+ (package
+ (name "obs-source-record")
+ (version "0.3.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/exeldro/obs-source-record")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07yglklrjn3nkyw8755nwchcfgvyw7d0n4qynvja8s7rgqbbs0an"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:configure-flags
+ #~(list (string-append "-DLIBOBS_INCLUDE_DIR="
+ #$(this-package-input "obs") "/lib")
+ "-DBUILD_OUT_OF_TREE=On"
+ "-Wno-dev")))
+ (inputs (list obs))
+ (home-page "https://github.com/exeldro/obs-source-record")
+ (synopsis "OBS plugin for recording sources via a filter")
+ (description "This package provides an OBS plugin for recording sources
+via a filter.")
+ (license license:gpl2)))
+
(define-public obs-websocket
;; Functionality was merged into OBS.
(deprecated-package "obs-websocket" obs))