summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-03-02 23:26:40 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:31 +0000
commitb577550c0026b27c0493480cac7852881eec4116 (patch)
tree8ec0bcd71ffef50b378803d1ae012c1df9d44145 /gnu/packages
parentd7abe61507572f040cefe788a6853dbd5959e205 (diff)
gnu: Add go-github-com-hashicorp-go-multierror.
* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-go-multierror): New variable. Change-Id: I6b09a52dc314c4cc6903690738debf4b6c99393f Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f488b17e61..08c3df44b5 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -792,6 +792,34 @@ Differentiation between text and binary files}.
wrapping errors and checking if an error contains another error.")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-go-multierror
+ (package
+ (name "go-github-com-hashicorp-go-multierror")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-multierror")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l4s41skdpifndn9s8y6s9vzgghdzg4z8z0lld9qjr28888wzp00"))))
+ (build-system go-build-system)
+ (inputs (list go-github-com-hashicorp-errwrap))
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/go-multierror"))
+ (home-page "https://github.com/hashicorp/go-multierror")
+ (synopsis "Representing a errors list as a single error for Golang")
+ (description
+ "@code{go-multierror} is Golang module providing a mechanism for
+representing a list of @code{error} values as a single @code{error}. It is
+fully compatible with the standard @code{errors} package, including
+the functions @code{As}, @code{Is}, and @code{Unwrap}. This provides a
+standardized approach for introspecting on error values.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-hhrutter-tiff
(package
(name "go-github-com-hhrutter-tiff")