summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-26 23:01:43 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-03 15:28:06 +0200
commitb5b08878b662a856117accb2df3c6c79d646bb14 (patch)
treee583a556c13f60e783c96c0ed428df14541cf1c3 /gnu/packages
parent9161ba818d14461c8a13afd3dc367b7a4c06ad62 (diff)
gnu: mutt: Don't retain reference to GCC.
* gnu/packages/patches/mutt-store-references.patch: New file. * gnu/packages/mail.scm (mutt)[source]: Use it. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm4
-rw-r--r--gnu/packages/patches/mutt-store-references.patch16
2 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 70b0b0298d..d14fdc7619 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -184,7 +184,9 @@ aliasing facilities to work just as they would on normal mail.")
(sha256
(base32
"0dzx4qk50pjfsb6cs5jahng96a52k12f7pm0sc78iqdrawg71w1s"))
- (patches (list (search-patch "mutt-CVE-2014-9116.patch")))))
+ (patches (map search-patch
+ '("mutt-CVE-2014-9116.patch"
+ "mutt-store-references.patch")))))
(build-system gnu-build-system)
(inputs
`(("cyrus-sasl" ,cyrus-sasl)
diff --git a/gnu/packages/patches/mutt-store-references.patch b/gnu/packages/patches/mutt-store-references.patch
new file mode 100644
index 0000000000..3b69c7b0bd
--- /dev/null
+++ b/gnu/packages/patches/mutt-store-references.patch
@@ -0,0 +1,16 @@
+By default 'mutt' embeds configure flags and the output of 'gcc -v',
+which contains the store file name of Bash and GCC. This patch makes
+sure we don't embed a reference to these in 'mutt'.
+
+--- mutt-1.5.23/txt2c.sh 2015-06-26 22:56:56.500731643 +0200
++++ mutt-1.5.23/txt2c.sh 2015-06-26 22:57:26.664583900 +0200
+@@ -21,6 +21,8 @@ txt2c_fallback () {
+ echo ";"
+ }
+
++echo "unsigned char $1[] = \"value of '$1' not kept\";"
++exit 0
+ ./txt2c test </dev/null >/dev/null 2>&1 &&
+ ./txt2c "$1" ||
+ txt2c_fallback "$1"
+