summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 12:28:19 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 12:28:19 +0200
commitb6e068d299b345bebac544e7a905627a6ed08fdd (patch)
treed556ea3ca125ebd4ec98a638bf4313f043cbae61 /gnu/packages
parenta62df7cd72423e9ea7cf030a4db034c548eeb59e (diff)
parentd8a046d560e8e149e903b7d3648c7218bf17c085 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm47
-rw-r--r--gnu/packages/gdb.scm3
-rw-r--r--gnu/packages/python-xyz.scm4
3 files changed, 50 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index de2f6534f8..9d9fd2d95d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -124,6 +124,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages tcl)
#:use-module (gnu packages terminals)
@@ -3863,3 +3864,49 @@ It supports mounting local filesystems of any kind the normal mount utility
supports. It can also mount encrypted LUKS volumes using the password
supplied by the user when logging in.")
(license (list license:gpl2+ license:lgpl2.1+))))
+
+(define-public jc
+ (package
+ (name "jc")
+ (version "1.11.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kellyjonbrazil/jc.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rkckbgm04ql4r48wjgljfiqvsz36n99yqcpcyna8lvlm8h4nmwa"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-ruamel.yaml" ,python-ruamel.yaml)
+ ("python-xmltodict" ,python-xmltodict)
+ ("python-pygments" ,python-pygments)))
+ (home-page "https://github.com/kellyjonbrazil/jc")
+ (synopsis "Convert the output of command-line tools to JSON")
+ (description "@code{jc} JSONifies the output of many CLI tools and
+file-types for easier parsing in scripts.")
+ (license license:expat)))
+
+(define-public jtbl
+ (package
+ (name "jtbl")
+ (version "1.1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kellyjonbrazil/jtbl.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zzd7rd63xva50f22d1rfja4r302aizrafarhwm67vv181swvdya"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-tabulate" ,python-tabulate)))
+ (home-page "https://github.com/kellyjonbrazil/jtbl")
+ (synopsis "Command-line tool to print JSON data as a table in the terminal")
+ (description "@code{jtbl} accepts piped JSON data from stdin and outputs a
+text table representation to stdout.")
+ (license license:expat)))
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 2615f1f158..56d37960f7 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -141,5 +141,4 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
gdb
(name "gdb-minimal")
(inputs (fold alist-delete (package-inputs gdb)
- '("guile" "libxml2" "ncurses" "python-wrapper"
- "source-highlight")))))
+ '("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index be27f2b60b..300277f045 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11691,13 +11691,13 @@ It uses LR parsing and does extensive error checking.")
(define-public python-tabulate
(package
(name "python-tabulate")
- (version "0.7.7")
+ (version "0.8.7")
(source (origin
(method url-fetch)
(uri (pypi-uri "tabulate" version))
(sha256
(base32
- "1inqhspd4frxnp08c32yndr0lc4px1xfkqah184i5w09gkhvi843"))))
+ "01shi7bmj09f0bcm5s0c9skys063lzp76p0n4a2xmg041ni269yv"))))
(build-system python-build-system)
(arguments
;; FIXME: The pypi release tarball is missing a 'test/common.py'