summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-01-28 20:20:01 -0800
committer宋文武 <iyzsong@member.fsf.org>2023-02-10 14:09:15 +0800
commitb8f6ead5faac3c1b9a8fa6e060c00cf0917e884e (patch)
tree0fdec4e95563b99da13818da9d4074ee57c6967b /gnu/packages
parent0ac85f3caa56bfdeffae295e174d1cae9bbdbfef (diff)
gnu: Add xnedit.
* gnu/packages/text-editors.scm (xnedit): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/text-editors.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 9c70b5c758..16400481b0 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,6 +75,7 @@
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages hunspell)
#:use-module (gnu packages image)
+ #:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
@@ -1379,3 +1381,35 @@ for configuration and extensibility. It provides emulation modes for the
key bindings of many editors (including Emacs and WordStar), and has syntax
highlighting for dozens of languages. Jed is very small and fast.")
(license license:gpl2+)))
+
+(define-public xnedit
+ (package
+ (name "xnedit")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xnedit/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0fw3li7hr47hckm9pl1njx30lfr6cx2p094ir8zmgr91hyxidgld"))))
+
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:tests? #f ;no tests
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "linux" make-flags))))))
+ (inputs (list motif pcre))
+ (native-inputs (list pkg-config))
+ (home-page "https://sourceforge.net/projects/xnedit/")
+ (synopsis "Fast and classic X11 text editor")
+ (description
+ "XNEdit is a fast and classic X11 text editor, based on NEdit,
+with full unicode support and antialiased text rendering.")
+ (license license:gpl2+)))