summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-11 19:25:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-11 19:25:16 +0100
commitc3f47e44cdcb9db3c70ef13526a33d538ed40aa9 (patch)
treecc9bc516924382932890a0a1cfec6bccd49e2d15 /gnu/packages
parentf9126dd404b61d7aeea8cf5ddcfb3b2829ac0f73 (diff)
parentc8b69863eb479c3b9d8a59c2cee3226986e40d02 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm22
-rw-r--r--gnu/packages/bootloaders.scm20
-rw-r--r--gnu/packages/curl.scm14
-rw-r--r--gnu/packages/django.scm4
-rw-r--r--gnu/packages/gnome.scm46
-rw-r--r--gnu/packages/gps.scm4
-rw-r--r--gnu/packages/haskell.scm108
-rw-r--r--gnu/packages/mail.scm7
-rw-r--r--gnu/packages/messaging.scm4
-rw-r--r--gnu/packages/mpd.scm31
-rw-r--r--gnu/packages/music.scm2
-rw-r--r--gnu/packages/patches/gnome-shell-theme.patch53
-rw-r--r--gnu/packages/python-crypto.scm8
-rw-r--r--gnu/packages/python-xyz.scm85
-rw-r--r--gnu/packages/qt.scm5
-rw-r--r--gnu/packages/ssh.scm3
-rw-r--r--gnu/packages/suckless.scm4
-rw-r--r--gnu/packages/syncthing.scm4
-rw-r--r--gnu/packages/upnp.scm4
-rw-r--r--gnu/packages/video.scm6
-rw-r--r--gnu/packages/xdisorg.scm2
21 files changed, 365 insertions, 71 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 64f826b3f0..12755dd7a7 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1892,19 +1892,17 @@ significantly faster and have minimal dependencies.")
(define-public lv2
(package
(name "lv2")
- (version "1.14.0")
+ (version "1.16.0")
(source (origin
(method url-fetch)
(uri (string-append "http://lv2plug.in/spec/lv2-"
version ".tar.bz2"))
(sha256
(base32
- "0chxwys3vnn3nxc9x2vchm74s9sx0vfra6y893byy12ci61jc1dq"))))
+ "1ppippbpdpv13ibs06b0bixnazwfhiw0d0ja6hx42jnkgdyp5hyy"))))
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no check target
- ;; XXX: The bundled waf does not work with Python 3.7.
- #:python ,python-2
#:configure-flags '("--no-plugins")))
(inputs
;; Leaving off cairo and gtk+-2.0 which are needed for example plugins
@@ -1920,22 +1918,6 @@ add functionality to support the needs of increasingly powerful audio
software.")
(license license:isc)))
-(define-public lv2-devel
- (let ((commit "39c7c726cd52b2863fcea356cafe1bcab2ba7f37")
- (revision "1"))
- (package (inherit lv2)
- (name "lv2-devel")
- (version (string-append "1.15.3-" revision "." (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "http://lv2plug.in/git/lv2.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1gp2rd99dfmpibvpixrqn115mrhybzf3if3h8bssf6siyi13f29r")))))))
-
(define-public lv2-mda-piano
(package
(name "lv2-mda-piano")
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 5bd784f73c..a566001b07 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -624,7 +624,25 @@ board-independent tools.")))
(make-u-boot-package "mx6cuboxi" "arm-linux-gnueabihf"))
(define-public u-boot-novena
- (make-u-boot-package "novena" "arm-linux-gnueabihf"))
+ (let ((base (make-u-boot-package "novena" "arm-linux-gnueabihf")))
+ (package
+ (inherit base)
+ (description "U-Boot is a bootloader used mostly for ARM boards. It
+also initializes the boards (RAM etc).
+
+This U-Boot is built for Novena. Be advised that this version, contrary
+to Novena upstream, does not load u-boot.img from the first patition.")
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'patch-novena-defconfig
+ ;; Patch configuration to disable loading u-boot.img from FAT partition,
+ ;; allowing it to be installed at a device offset.
+ (lambda _
+ (substitute* "configs/novena_defconfig"
+ (("CONFIG_SPL_FAT_SUPPORT=y") "# CONFIG_SPL_FAT_SUPPORT is not set"))
+ #t)))))))))
(define-public u-boot-cubieboard
(make-u-boot-package "Cubieboard" "arm-linux-gnueabihf"))
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 24180e0073..12a82d1bb7 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -50,6 +50,7 @@
(define-public curl
(package
(name "curl")
+ (replacement curl-7.64.0)
(version "7.63.0")
(source (origin
(method url-fetch)
@@ -141,6 +142,19 @@ tunneling, and so on.")
"See COPYING in the distribution."))
(home-page "https://curl.haxx.se/")))
+(define-public curl-7.64.0
+ (package
+ (inherit curl)
+ (version "7.64.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://curl.haxx.se/download/curl-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "00b0mw4fc1pbmbh55maab24x3ijdvkbpl1s4njfa4jnl6kx16brg"))))))
+
(define-public kurly
(package
(name "kurly")
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index a2fa1db036..bce84449e1 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -38,13 +38,13 @@
(define-public python-django
(package
(name "python-django")
- (version "1.11.18")
+ (version "1.11.20")
(source (origin
(method url-fetch)
(uri (pypi-uri "Django" version))
(sha256
(base32
- "19b6f020als9hr4q1im5282yn2b1hzf586n9kjrlkrslq7da3k3k"))))
+ "0h90kdq8r4y8wa73hdxmyy5psnwlg61dcq3qsa098cpfiyh9vaa3"))))
(build-system python-build-system)
(arguments
'(#:modules ((srfi srfi-1)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b05b2d7879..3a09ae373c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
@@ -126,6 +126,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages rdesktop)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages samba)
#:use-module (gnu packages scanner)
#:use-module (gnu packages selinux)
@@ -149,6 +150,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xorg)
+ #:use-module (gnu artwork)
#:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
@@ -159,6 +161,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (guix gexp)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
@@ -4572,16 +4575,6 @@ such as gzip tarballs.")
(out (assoc-ref outputs "out")))
(wrap-program (string-append out "/bin/gnome-session")
`("PATH" ":" prefix (,(string-append glib "/bin"))))
- #t)))
- (add-after 'install 'disable-hardware-acceleration-check
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Do not abort if hardware acceleration is missing. This allows
- ;; GNOME to run in QEMU and on low-end devices.
- (let ((out (assoc-ref outputs "out")))
- (substitute* (string-append out
- "/share/xsessions/gnome.desktop")
- (("gnome-session")
- "gnome-session --disable-acceleration-check"))
#t))))
#:configure-flags
@@ -5580,11 +5573,37 @@ properties, screen resolution, and other GNOME parameters.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1f20x36ymkp1j667hb7s7byly2gqc4m0anldy3qwp38vm8437caq"))))
+ "1f20x36ymkp1j667hb7s7byly2gqc4m0anldy3qwp38vm8437caq"))
+ (patches (search-patches "gnome-shell-theme.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; CSS files have to be regenerated from the .scss source
+ ;; that 'gnome-shell-theme.patch' modifies.
+ (for-each delete-file
+ (find-files "data/theme"
+ "^gnome-shell.*\\.css$"))
+
+ ;; Copy images for use on the GDM log-in screen.
+ (copy-file #$(file-append %artwork-repository
+ "/slim/0.x/background.png")
+ "data/theme/guix-background.png")
+ (invoke #+(file-append inkscape "/bin/inkscape")
+ "--export-png=data/theme/guix-logo.png"
+ #$(file-append %artwork-repository
+ "/logo/Guix-horizontal-white.svg"))
+ #t))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-before 'build 'rebuild-css
+ (lambda _
+ ;; Rebuild the CSS files from the .scss files that our patch
+ ;; modifies.
+ (invoke "make" "-C" "data"
+ "theme/gnome-shell.css"
+ "theme/gnome-shell-high-contrast.css")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -5614,7 +5633,8 @@ properties, screen resolution, and other GNOME parameters.")
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("python" ,python)
- ("xsltproc" ,libxslt)))
+ ("xsltproc" ,libxslt)
+ ("ruby-sass" ,ruby-sass)))
(inputs
`(("accountsservice" ,accountsservice)
("caribou" ,caribou)
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 92f6a4f977..3f3fe8fcb5 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -147,7 +147,7 @@ between two other data points.")
(define-public gama
(package
(name "gama")
- (version "2.02")
+ (version "2.03")
(source
(origin
(method url-fetch)
@@ -155,7 +155,7 @@ between two other data points.")
version ".tar.gz"))
(sha256
(base32
- "1r5rrmiqdg6dpxqla0f2mjwcjzlckdjpg4ar0cirmz78w78hf6vn"))))
+ "0d33yyasnx54c6i40rkr9by4qv92rqb8wkmp5r46nz7bbp9kpymv"))))
(build-system gnu-build-system)
(arguments '(#:parallel-tests? #f)) ; race condition
(native-inputs
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 255e902e66..21a5177927 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11493,4 +11493,112 @@ imported with the correct Haskell types.")
Music Player Daemon.")
(license license:expat)))
+(define-public ghc-alsa-core
+ (package
+ (name "ghc-alsa-core")
+ (version "0.5.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/alsa-core/alsa-core-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1avh4a419h9d2zsslg6j8hm87ppgsgqafz8ll037rk2yy1g4jl7b"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+ ("alsa-lib" ,alsa-lib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://www.haskell.org/haskellwiki/ALSA")
+ (synopsis "Binding to the ALSA Library API (Exceptions)")
+ (description "This package provides access to ALSA infrastructure, that is
+needed by both alsa-seq and alsa-pcm.")
+ (license license:bsd-3)))
+
+(define-public ghc-base-unicode-symbols
+ (package
+ (name "ghc-base-unicode-symbols")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/base-unicode-symbols/base-unicode-symbols-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1ia6li7qjg1zkak4gf6mnbshw45mq9bfjr0jch58ds0lscmvwyzf"))))
+ (build-system haskell-build-system)
+ (home-page "http://www.haskell.org/haskellwiki/Unicode-symbols")
+ (synopsis "Unicode alternatives for common functions and operators")
+ (description "This package defines new symbols for a number of functions,
+operators and types in the base package. All symbols are documented with
+their actual definition and information regarding their Unicode code point.
+They should be completely interchangeable with their definitions. For
+further Unicode goodness you can enable the @code{UnicodeSyntax}
+@url{https://downloads.haskell.org/~ghc/latest/docs/html/users_guide/glasgow_exs.html#unicode-syntax,
+language extension}. This extension enables Unicode characters to be used to
+stand for certain ASCII character sequences, i.e. → instead of @code{->},
+∀ instead of @code{forall} and many others.")
+ (license license:bsd-3)))
+
+(define-public ghc-stylish-haskell
+ (package
+ (name "ghc-stylish-haskell")
+ (version "0.9.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/stylish-haskell/stylish-haskell-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1ls11fdx6snvfx8yykpidz142zzxwi5bazl49hgfqlwx50rqcp7w"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-file-embed" ,ghc-file-embed)
+ ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-yaml" ,ghc-yaml)
+ ("ghc-strict" ,ghc-strict)
+ ("ghc-optparse-applicative"
+ ,ghc-optparse-applicative)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
+ (home-page "https://github.com/jaspervdj/stylish-haskell")
+ (synopsis "Haskell code prettifier")
+ (description "Stylish-haskell is a Haskell code prettifier. The goal is
+not to format all of the code in a file, to avoid \"getting in the way\".
+However, this tool can e.g. clean up import statements and help doing various
+tasks that get tedious very quickly. It can
+@itemize
+@item
+Align and sort @code{import} statements
+@item
+Group and wrap @code{{-# LANGUAGE #-}} pragmas, remove (some) redundant
+pragmas
+@item
+Remove trailing whitespaces
+@item
+Align branches in @code{case} and fields in records
+@item
+Convert line endings (customisable)
+@item
+Replace tabs by four spaces (turned off by default)
+@item
+Replace some ASCII sequences by their Unicode equivalent (turned off by
+default)
+@end itemize")
+ (license license:bsd-3)))
;;; haskell.scm ends here
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 8ae069ba52..301298082a 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1200,15 +1200,16 @@ facilities for checking incoming mail.")
(define-public dovecot
(package
(name "dovecot")
- (version "2.3.4")
+ (version "2.3.4.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.dovecot.org/releases/"
(version-major+minor version) "/"
name "-" version ".tar.gz"))
- (sha256 (base32
- "01ggzf7b3jpl89mjiqr7xbpbs181g2gjf6wzg70qaqfzz3ppc6yr"))))
+ (sha256
+ (base32
+ "01xa8d08c0j51w5kmqb3vnzrvh17hkzx5a5p7fb5hgn3wln3x1xq"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index d8ec64f6c3..1991528a53 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1238,7 +1238,7 @@ with several different talk daemons at the same time.")
(define-public gloox
(package
(name "gloox")
- (version "1.0.21")
+ (version "1.0.22")
(source
(origin
(method url-fetch)
@@ -1246,7 +1246,7 @@ with several different talk daemons at the same time.")
version ".tar.bz2"))
(sha256
(base32
- "1k57qgif1yii515m6jaqaibkdysfab6394bpawd2l67321f1a4rw"))))
+ "0r69gq8if9yy1amjzl7qrq9lzhhna7qgz905ln4wvkwchha1ppja"))))
(build-system gnu-build-system)
(inputs
`(("libidn" ,libidn)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index bf12239a02..7885e21aa4 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
-;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2018, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -91,7 +91,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
(define-public mpd
(package
(name "mpd")
- (version "0.20.23")
+ (version "0.21.4")
(source (origin
(method url-fetch)
(uri
@@ -100,18 +100,19 @@ interfacing MPD in the C, C++ & Objective C languages.")
"/mpd-" version ".tar.xz"))
(sha256
(base32
- "1smg6hab4kwrzsw1k7vlpya3ampdk8psnmkrzxlgb43j4fgmygjh"))))
- (build-system gnu-build-system)
+ "1ix52vfa8k8my4xyr8b0phg8605b2xchyzyva908m08vpzm14w94"))))
+ (build-system meson-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags '("-Ddocumentation=true") ; The default is 'false'...
+ #:phases
(modify-phases %standard-phases
- (add-after 'install 'install-service-files
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (systemd (string-append out "/etc/systemd/system"))
- (systemd-user (string-append out "/etc/systemd/user")))
- (install-file "systemd/system/mpd.service" systemd)
- (install-file "systemd/user/mpd.service" systemd-user)
+ (add-before 'configure 'expand-C++-include-path
+ ;; Make <gcc>/include/c++/ext/string_conversions.h find <stdlib.h>.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((path "CPLUS_INCLUDE_PATH")
+ (gcc (assoc-ref inputs "gcc"))
+ (c++ (string-append gcc "/include/c++")))
+ (setenv path (string-append c++ ":" (getenv path)))
#t))))))
(inputs `(("ao" ,ao)
("alsa-lib" ,alsa-lib)
@@ -134,7 +135,11 @@ interfacing MPD in the C, C++ & Objective C languages.")
("pulseaudio" ,pulseaudio)
("sqlite" ,sqlite)
("zlib" ,zlib)))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ ;; MPD > 0.21 requires > GCC 6
+ (native-inputs `(("gcc" ,gcc-8)
+ ("gcc-lib" ,gcc-8 "lib")
+ ("pkg-config" ,pkg-config)
+ ("python-sphinx" ,python-sphinx)))
;; Missing optional inputs:
;; libyajl
;; libcdio_paranoia
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c4333364e1..f1733b7ae1 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3374,7 +3374,7 @@ plugins, a switch trigger, a toggle switch, and a peakmeter.")
("python-rdflib" ,python-rdflib)
("python" ,python)
("jack" ,jack-1)
- ("lv2" ,lv2-devel)
+ ("lv2" ,lv2)
("lilv" ,lilv)
("raul" ,raul-devel)
("ganv" ,ganv-devel)
diff --git a/gnu/packages/patches/gnome-shell-theme.patch b/gnu/packages/patches/gnome-shell-theme.patch
new file mode 100644
index 0000000000..fc7f7caf0f
--- /dev/null
+++ b/gnu/packages/patches/gnome-shell-theme.patch
@@ -0,0 +1,53 @@
+Adjust GNOME-Shell so that it uses a Guix theme by default.
+
+Patch by Ludovic Courtès <ludo@gnu.org>.
+
+diff --git a/data/gnome-shell-theme.gresource.xml b/data/gnome-shell-theme.gresource.xml
+index 76aeaa5..8eaf32e 100644
+--- a/data/gnome-shell-theme.gresource.xml
++++ b/data/gnome-shell-theme.gresource.xml
+@@ -22,6 +22,8 @@
+ <file>no-events.svg</file>
+ <file>no-notifications.svg</file>
+ <file>noise-texture.png</file>
++ <file>guix-background.png</file>
++ <file>guix-logo.png</file>
+ <file>pad-osd.css</file>
+ <file>page-indicator-active.svg</file>
+ <file>page-indicator-inactive.svg</file>
+diff --git a/data/theme/gnome-shell-sass/_common.scss b/data/theme/gnome-shell-sass/_common.scss
+index 54d9f39..b9badd0 100644
+--- a/data/theme/gnome-shell-sass/_common.scss
++++ b/data/theme/gnome-shell-sass/_common.scss
+@@ -1742,7 +1742,16 @@ $legacy_icon_size: 24px;
+
+ }
+
+- .login-dialog-logo-bin { padding: 24px 0px; }
++ .login-dialog-logo-bin {
++ /* Make it a bit narrower than .login-dialog-user-list. */
++ width: 12em;
++ height: 8em;
++ background: url(resource:///org/gnome/shell/theme/guix-logo.png);
++ background-color: transparent;
++ background-repeat: no-repeat;
++ background-size: contain;
++ background-position: center; }
++
+ .login-dialog-banner { color: darken($osd_fg_color,10%); }
+ .login-dialog-button-box { spacing: 5px; }
+ .login-dialog-message-warning { color: $warning_color; }
+@@ -1889,9 +1898,10 @@ $legacy_icon_size: 24px;
+ }
+
+ #lockDialogGroup {
+- background: #2e3436 url(resource:///org/gnome/shell/theme/noise-texture.png);
+- background-repeat: repeat;
+-}
++ background: #2e3436 url(resource:///org/gnome/shell/theme/guix-background.png);
++ background-repeat: no-repeat;
++ background-size: cover;
++ background-position: center; }
+
+ #screenShieldNotifications {
+ StButton#vhandle, StButton#hhandle {
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 077330e54a..2e08243178 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -743,14 +743,14 @@ file, and more.")
(define-public python-ecpy
(package
(name "python-ecpy")
- (version "0.8.2")
+ (version "0.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ECPy" version))
(sha256
(base32
- "090fqnj8z0xm44jrfpll7j45r68m6kp7mjr7yxzg93j42h3sj285"))))
+ "1gc3i5s93zq6x1nkaxkq1dvmsc12vmrw0hns9f5s1hcb78ni52c8"))))
(build-system python-build-system)
(propagated-inputs
`(("python-future" ,python-future)))
@@ -803,14 +803,14 @@ protocol (Javascript Object Signing and Encryption).")
(define-public python-pycryptodome
(package
(name "python-pycryptodome")
- (version "3.7.2")
+ (version "3.7.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pycryptodome" version))
(sha256
(base32
- "1xxf5cyhlc5ak5skf4zgqz9yk5fj5g70hd06hc1jym995lxpxz7m"))))
+ "0dh6ky5ngxayyn5f6n7gdamjl49g3khz6pdx9sdnag1zwi8248hs"))))
(build-system python-build-system)
(home-page "https://www.pycryptodome.org")
(synopsis "Cryptographic library for Python")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9545321461..802f636b88 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1938,6 +1938,40 @@ easier to build concurrent applications.")
(define-public python2-pykka
(package-with-python2 python-pykka))
+(define-public python-pymsgbox
+ (package
+ (name "python-pymsgbox")
+ (version "1.0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; LICENSE.txt is not present on pypi
+ (url "https://github.com/asweigart/PyMsgBox")
+ (commit "55926b55f46caa969c5ddb87990ebea2737bd66f")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zy7rjfpwlrd8b64j7jk2lb8m2npc21rnpwakpfvwgl4nxdy80rg"))))
+ (arguments
+ ;; Circular dependency to run tests:
+ ;; Tests need pyautogui, which depends on pymsgbox.
+ '(#:tests? #f))
+ (build-system python-build-system)
+ (home-page "https://github.com/asweigart/PyMsgBox")
+ (synopsis "Python module for JavaScript-like message boxes")
+ (description
+ "PyMsgBox is a simple, cross-platform, pure Python module for
+JavaScript-like message boxes. Types of dialog boxes include:
+@enumerate
+@item alert
+@item confirm
+@item prompt
+@item password
+@end enumerate
+")
+ (license license:bsd-3)))
+
(define-public python-pympler
(package
(name "python-pympler")
@@ -2189,6 +2223,57 @@ logging and tracing of the execution.")
(define-public python2-joblib
(package-with-python2 python-joblib))
+(define-public python-daemon
+ (package
+ (name "python-daemon")
+ (version "2.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-daemon" version))
+ (sha256
+ (base32
+ "09fcjdjzk9ywmpnrj62iyxqgcygzdafsz41qlrk2dknzbagcmzmg"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-tests
+ (lambda _
+ ;; FIXME: Determine why test fails
+ (substitute* "test/test_daemon.py"
+ (("test_detaches_process_context")
+ "skip_test_detaches_process_context"))
+ #t)))))
+ (propagated-inputs
+ `(("python-lockfile" ,python-lockfile)))
+ (native-inputs
+ `(("python-unittest2" ,python-unittest2)
+ ("python-testtools" ,python-testtools)
+ ("python-testscenarios" ,python-testscenarios)
+ ("python-mock" ,python-mock)
+ ("python-docutils" ,python-docutils)))
+ (home-page "https://pagure.io/python-daemon/")
+ (synopsis "Python library for making a Unix daemon process")
+ (description "Python-daemon is a library that assists a Python program to
+turn itself into a well-behaved Unix daemon process, as specified in PEP 3143.
+
+This library provides a @code{DaemonContext} class that manages the following
+important tasks for becoming a daemon process:
+@enumerate
+@item Detach the process into its own process group.
+@item Set process environment appropriate for running inside a chroot.
+@item Renounce suid and sgid privileges.
+@item Close all open file descriptors.
+@item Change the working directory, uid, gid, and umask.
+@item Set appropriate signal handlers.
+@item Open new file descriptors for stdin, stdout, and stderr.
+@item Manage a specified PID lock file.
+@item Register cleanup functions for at-exit processing.
+@end enumerate")
+ ;; Only setup.py is gpl3+, everything else is apache 2.0 licensed.
+ (license (list license:asl2.0 license:gpl3+))))
+
(define-public python-docutils
(package
(name "python-docutils")
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2e8f2d1135..6775a991b9 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2173,6 +2173,11 @@ different kinds of sliders, and much more.")
(arguments
`(#:tests? #f ; no apparent tests; it might be necessary to set
; ENABLE_API_TESTS, see CMakeLists.txt
+
+ ;; Parallel builds fail due to a race condition:
+ ;; <https://bugs.gnu.org/34062>.
+ #:parallel-build? #f
+
#:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
"-DPORT=Qt"
"-DUSE_LIBHYPHEN=OFF"
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 682989ae29..1928ea7634 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -456,6 +456,9 @@ TCP, not the SSH protocol.")
"0rgavbzw7jrs5wslxm0dnwx2m409yzxd9hazd92r7kx8xikr3yzj"))))
(build-system gnu-build-system)
(arguments `(#:tests? #f)) ; there is no "make check" or anything similar
+ ;; TODO: Investigate unbundling libtommath and libtomcrypt or at least
+ ;; cherry-picking important bug fixes from them. See <bugs.gnu.org/24674>
+ ;; for more information.
(inputs `(("zlib" ,zlib)))
(synopsis "Small SSH server and client")
(description "Dropbear is a relatively small SSH server and
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 6edeea6cac..1b5e21845c 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -137,14 +137,14 @@ optimising the environment for the application in use and the task performed.")
(define-public dmenu
(package
(name "dmenu")
- (version "4.8")
+ (version "4.9")
(source (origin
(method url-fetch)
(uri (string-append "https://dl.suckless.org/tools/dmenu-"
version ".tar.gz"))
(sha256
(base32
- "0qfvfrj10xlwd9hkvb57wshryan65bl6423h0qhiw1h76rf5lqgy"))))
+ "0ia9nqr83bv6x247q30bal0v42chcj9qcjgv59xs6xj46m7iz5xk"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no tests
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 92eda1c9b1..e4f8c09016 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -30,7 +30,7 @@
(define-public syncthing
(package
(name "syncthing")
- (version "1.0.0")
+ (version "1.0.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
@@ -38,7 +38,7 @@
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "0992nsdiw374pbh1dywg7c2jijzy4xmsv0b7q5p76xn2yyg5yhr7"))
+ "0gas07lxm5d2c21axgcs90r779rj9sk3jymnnffxz457rvpr2qn3"))
;; Since the update to Go 1.11, Go programs have been keeping
;; spurious references to all their dependencies:
;; <https://bugs.gnu.org/33620>.
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index e7da5b30c0..9d534e5799 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -32,14 +32,14 @@
(define-public miniupnpc
(package
(name "miniupnpc")
- (version "2.1")
+ (version "2.1.20190210")
(source
(origin
(method url-fetch)
(uri (string-append "https://miniupnp.tuxfamily.org/files/"
name "-" version ".tar.gz"))
(sha256
- (base32 "1ik440yspbp3clr4m01xsl9skwyrzcvzb5nbm3i0g9x53vhbb7z1"))))
+ (base32 "05w8p51yd71ksapajb9nag464ncakk72v9dxr01y168wix707d49"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-2)))
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3b3b256e92..d4cc4b53e1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -683,14 +683,14 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
(define-public ffmpeg
(package
(name "ffmpeg")
- (version "4.1")
+ (version "4.1.1")
(source (origin
(method url-fetch)
(uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
version ".tar.xz"))
(sha256
(base32
- "150rrm549fy1x71c9whmyi5knyd9sliwvmcsm438bdgg4v8c93m3"))))
+ "11id9pm4azfrhpa4vr2yaw31dzgd55kl1zsxwn24sczx9n14jdrp"))))
(build-system gnu-build-system)
(inputs
`(("fontconfig" ,fontconfig)
@@ -992,7 +992,7 @@ videoformats depend on the configuration flags of ffmpeg.")
("libva" ,libva)
("libvdpau" ,libvdpau)
("libvorbis" ,libvorbis)
- ("libvpx" ,libvpx)
+ ("libvpx" ,libvpx-1.7)
("libtheora" ,libtheora)
("libx264" ,libx264)
("libxext" ,libxext)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 7613accb4f..5359c4c9d9 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -302,7 +302,7 @@ following the mouse.")
(source (origin
(method url-fetch)
(uri (string-append
- "http://cairographics.org/releases/pixman-"
+ "https://www.cairographics.org/releases/pixman-"
version ".tar.gz"))
(sha256
(base32