summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-03-03 13:07:23 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-03-03 15:11:43 +0100
commitc6480edbe3260a3bfb48361ca73e666b6d473f42 (patch)
tree6f36f87278042a49793d4e39002867d1a6a6706c /gnu/packages
parent03ef0914d5cb561ab1e0091c88457e6538b0231f (diff)
gnu: Add r-seurat-utils.
* gnu/packages/bioinformatics.scm (r-seurat-utils): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cb6f6c5af1..85b81b2c81 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15939,6 +15939,60 @@ information... The package can also be used to extract data from @code{.loom}
files.")
(license license:expat))))
+(define-public r-seurat-utils
+ (let ((commit "0b6f5b548a49148cfbeaa654e8a618c0a020afa5")
+ (revision "1"))
+ (package
+ (name "r-seurat-utils")
+ (version (git-version "1.6.5" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vertesy/Seurat.utils")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mn64h375mkj6x4ix5493z32gqg96yc507j5jr0lx9g5wk1bf762"))))
+ (properties `((upstream-name . "Seurat.utils")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-codeandroll2
+ r-cowplot
+ r-dplyr
+ r-ggcorrplot
+ r-ggexpress
+ r-ggplot2
+ r-ggpubr
+ r-ggrepel
+ r-hgnchelper
+ r-htmlwidgets
+ r-markdownhelpers
+ r-markdownreports
+ r-matrix
+ r-matrixstats
+ r-princurve
+ r-r-utils
+ r-readr
+ r-readwriter
+ r-reshape2
+ r-scales
+ r-seurat
+ r-soupx
+ r-sparsematrixstats
+ r-stringendo
+ r-stringr
+ r-tibble
+ r-tictoc
+ r-vroom))
+ (home-page "https://github.com/vertesy/Seurat.utils")
+ (synopsis "Collection of utility functions for Seurat")
+ (description
+ "This is a collection of utility functions for Seurat. These functions
+allow the automation and multiplexing of plotting, 3D plotting, visualization
+of statistics & QC, interaction with the Seurat object. Some functionalities
+require functions from CodeAndRoll and MarkdownReports libraries.")
+ (license license:gpl3))))
+
(define-public r-seuratwrappers
;; There are no releases or tags.
(let ((commit "d28512f804d5fe05e6d68900ca9221020d52cf1d")