summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:05:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:31 +0200
commitd822f3aaace66e0a8c2088f013091fef345048c9 (patch)
tree8705ae77b25773333bb210aea03be7b185333c8e /gnu/packages
parent21e09455fc0c255bd95cbeebc1e06ffe4e85dd0d (diff)
gnu: Add texlive-newpax.
* gnu/packages/tex.scm (texlive-newpax): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7efe04edac..68a5d92199 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6357,6 +6357,28 @@ the LaTeX standard foating environments @code{figure} and @code{table}.")
(define-deprecated-package texlive-latex-newfloat texlive-newfloat)
+(define-public texlive-newpax
+ (package
+ (name "texlive-newpax")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/newpax/" "source/latex/newpax/"
+ "tex/latex/newpax/")
+ (base32
+ "1b8z1k9gn0g1q6qyixgwds61b2844kiqb0sfvhn9x38fnqgzy83j")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/newpax")
+ (synopsis "Experimental package to extract and reinsert PDF annotations")
+ (description
+ "The package is based on the @code{pax} package from Heiko Oberdiek. It
+offers a Lua-based alternative to the java based @file{pax.jar} to extract the
+annotations from a PDF. The resulting file can then be used together with
+@file{pax.sty}. It also offers an extended style which works with all three
+major engines.")
+ (license license:lppl1.3c)))
+
(define-public texlive-newunicodechar
(package
(name "texlive-newunicodechar")