summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:40:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:49 +0300
commitda12e8f7c79aa3821678721c168965325bd83c5b (patch)
tree13bdb2c37a9051a7a263ca2ef8400fe19122469d /gnu/packages
parent8ca2dc09b7cf06e12bb43e41ac9dc852f495c1b4 (diff)
gnu: julia-libtiff-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-libtiff-jll): Move to ... * gnu/packages/julia-jll.scm: ... here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-jll.scm39
-rw-r--r--gnu/packages/julia-xyz.scm41
2 files changed, 39 insertions, 41 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index c5fbf930ce..e8d382afea 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -234,6 +234,45 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
(description "This package provides a wrapper for the libpng library.")
(license license:expat)))
+(define-public julia-libtiff-jll
+ (package
+ (name "julia-libtiff-jll")
+ (version "4.1.0+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Libtiff_jll.jl")
+ (commit (string-append "Libtiff-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07zzhmwmh2g4645ghv76z40hza2ghlb7sw15b1pii7f9kfcsgf45"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Libtiff\"")
+ (string-append "\"" (assoc-ref inputs "libtiff") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libtiff" ,libtiff)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)
+ ("julia-zstd-jll" ,julia-zstd-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Libtiff_jll.jl")
+ (synopsis "Libtiff library wrappers")
+ (description "This package provides a wrapper for libtiff")
+ (license license:expat)))
+
(define-public julia-mbedtls-jll
(package
(name "julia-mbedtls-jll")
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 659b490425..2fe172b6d3 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -23,7 +23,6 @@
#:use-module (guix packages)
#:use-module (guix git-download)
#:use-module (guix build-system julia)
- #:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages julia-jll))
@@ -1015,46 +1014,6 @@ Cassette.")
and printing JSON documents.")
(license license:expat)))
-(define-public julia-libtiff-jll
- (package
- (name "julia-libtiff-jll")
- (version "4.1.0+1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaBinaryWrappers/Libtiff_jll.jl")
- (commit (string-append "Libtiff-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "07zzhmwmh2g4645ghv76z40hza2ghlb7sw15b1pii7f9kfcsgf45"))))
- (build-system julia-build-system)
- (arguments
- '(#:tests? #f ; no runtests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
- (lambda* (#:key inputs #:allow-other-keys)
- (map
- (lambda (wrapper)
- (substitute* wrapper
- (("artifact\"Libtiff\"")
- (string-append "\"" (assoc-ref inputs "libtiff") "\""))))
- ;; There's a Julia file for each platform, override them all
- (find-files "src/wrappers/" "\\.jl$")))))))
- (inputs
- `(("libtiff" ,libtiff)))
- (propagated-inputs
- `(("julia-jllwrappers" ,julia-jllwrappers)
- ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
- ("julia-zlib-jll" ,julia-zlib-jll)
- ("julia-zstd-jll" ,julia-zstd-jll)))
- (home-page "https://github.com/JuliaBinaryWrappers/Libtiff_jll.jl")
- (synopsis "Libtiff library wrappers")
- (description "This package provides a wrapper for libtiff")
- (license license:expat)))
-
(define-public julia-macrotools
(package
(name "julia-macrotools")