summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:48:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:19 +0200
commitdf7913fbe0a3280c0250fe4622a102d0edfb6a78 (patch)
tree3dd3f819df7f51eb273387706d6139f21a306d73 /gnu/packages
parent341075687fbd1b411e1339a8d8083d2278358d38 (diff)
gnu: Add texlive-luaaddplot.
* gnu/packages/tex.scm (texlive-luaaddplot): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c2bc7f19af..421d158766 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16282,6 +16282,28 @@ compatible with all LuaTeX and LuaMetaTeX-based formats.")
;; Use either license.
(license (list license:mpl2.0 license:cc-by-sa4.0))))
+(define-public texlive-luaaddplot
+ (package
+ (name "texlive-luaaddplot")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/luaaddplot/"
+ "source/luatex/luaaddplot/"
+ "tex/luatex/luaaddplot/")
+ (base32
+ "0r7n2s8isw3rm0g2l0zljh86ysh1zyfbmypci3kgciad5smjzx15")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luaaddplot")
+ (synopsis "Extension to @code{pgfplots}' @code{\\addplot} macro")
+ (description
+ "This package is an extension to @code{pgfplots}. It extends the
+@code{\\addplot} macro by a facility which allows modification of data files
+while they are read. With @code{luaaddplot} it is no longer necessary to
+pre-process data files generated by measuring devices with external scripts.")
+ (license license:lppl1.3+)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")