summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-15 16:58:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-15 17:30:57 +0200
commitdfa2e5b44bb026a7dcbc29134b6831d611e41b86 (patch)
tree27254018834284cd884159a943f53f508a978878 /gnu/packages
parentec2c7d454637257b0ad33f16a9573d53afe086d3 (diff)
gnu: alpine: Update to 2.25.
* gnu/packages/mail.scm (alpine): Update to 2.25. [source]: Add patch. Don't explicitly return #t from snippet. [arguments]: Nor from phases. * gnu/packages/patches/alpine-fix-privacy-policy-crash.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 42231f8283..aa73261350 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3708,7 +3708,7 @@ operators and scripters.")
(define-public alpine
(package
(name "alpine")
- (version "2.24.2")
+ (version "2.25")
(source
(origin
(method git-fetch)
@@ -3721,13 +3721,14 @@ operators and scripters.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0ibwss04j4qbhpd3jcw3d4xjf8jnmb9fi3sz58a99xw3awkfjabd"))
+ (base32 "0z6dp3cpz1dmbxw41ravsx1bxychafp0ij8gvj96mzz7rm9pdnq3"))
(modules '((guix build utils)))
(snippet
'(begin
;; Remove pre-built binaries scattered across the source repository.
- (for-each delete-file (find-files "." "\\.(dll|exe)"))
- #t))))
+ (for-each delete-file (find-files "." "\\.(dll|exe)"))))
+ (patches
+ (search-patches "alpine-fix-privacy-policy-crash.patch"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -3753,14 +3754,12 @@ operators and scripters.")
;; ‘/etc/shadow exists in the build environment’. It does not.
(lambda _
(substitute* "configure"
- (("test -f /etc/shadow") "true"))
- #t))
+ (("test -f /etc/shadow") "true"))))
(add-after 'unpack 'make-reproducible
(lambda _
;; This removes time-dependent code to make alpine reproducible.
(substitute* "pico/blddate.c"
- (("%02d-%s-%d") "1970-01-01"))
- #t)))))
+ (("%02d-%s-%d") "1970-01-01")))))))
(inputs
`(("ncurses" ,ncurses)
("openssl" ,openssl)