summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-22 22:01:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:21 +0200
commite3874552a256bb92a0ca1db5c5c911aa84edf956 (patch)
tree68c4b50090d6763c007f2ac8db028f61f0d66689 /gnu/packages
parent783ceeedb68c1faed35c88b7ecfb7944931a26dd (diff)
gnu: Remove rust-unwrap-1.
* gnu/packages/crates-io.scm (rust-unwrap-1): Delete variable. Change-Id: I26bb4d9c2c21b54dbf437b6e05d42f1830c78d56
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d8413abf77..ed1dadbeac 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -74703,30 +74703,6 @@ untrusted inputs in Rust.")
(sha256
(base32 "0byf88b7ca1kb5aap8f6npp6xncvg95dnma8ipmnmd4n9r5izkam"))))))
-(define-public rust-unwrap-1
- (package
- (name "rust-unwrap")
- (version "1.2.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "unwrap" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "03y24m63l85ng23z19bg7vwn6g1h1asg6ldyqwifca23sy6n8cvy"))))
- (build-system cargo-build-system)
- (home-page "https://github.com/canndrew/unwrap")
- (synopsis "unwrap! and unwrap_err! macros")
- (description
- "This crate provides two macros, @code{unwrap!} and @code{unwrap_err!}.
-The former can be used to unwrap values of type @code{Result} or @code{Option}
-(or any type that implements VerboseUnwrap) and is comparable to calling
-@code{unwrap()}. The latter can be used to unwrap an error from a
-@code{Result} (or any type that implements @code{VerboseUnwrapErr}) and is
-comparable to calling @code{unwrap_err()}.")
- (license (list license:expat license:bsd-3))))
-
(define-public rust-ureq-2
(package
(name "rust-ureq")