summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-22 17:17:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-23 18:31:46 +0100
commite982500fa6fb272de2403ec3eb6bfd30a2c55694 (patch)
tree39c5cef6b6fe0e3a060a9bd29808309499359c6f /gnu/packages
parenta512246ccd77b8b3c680c6f99bddd5da45a6b877 (diff)
gnu: Add emacs-sly.
* gnu/packages/emacs.scm (emacs-sly): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a6bae80c3a..81e6885f66 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4286,6 +4286,52 @@ are pretty much the same (and SLIME served as the principle inspiration for
CIDER).")
(license license:gpl3+)))
+;; There hasn't been a tag or release since 2015, so we take the latest
+;; commit.
+(define-public emacs-sly
+ (let ((commit "486bfbe95612bcdc0960c490207970a188e0fbb9")
+ (revision "1"))
+ (package
+ (name "emacs-sly")
+ (version (string-append "1.0.0-" revision "." (string-take commit 9)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joaotavora/sly.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ib4q4k3h3qn88pymyjjmlmnpizdn1mfg5gpk5a715nqsgxlg09l"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:include (cons "^lib\\/" %default-include)
+ #:phases
+ ;; The package provides autoloads.
+ (modify-phases %standard-phases
+ (delete 'make-autoloads))))
+ (home-page "https://github.com/joaotavora/sly")
+ (synopsis "Sylvester the Cat's Common Lisp IDE")
+ (description
+ "SLY is Sylvester the Cat's Common Lisp IDE. SLY is a fork of SLIME, and
+contains the following improvements over it:
+
+@enumerate
+@item Completely redesigned REPL based on Emacs's own full-featured
+ @code{comint.el}
+@item Live code annotations via a new @code{sly-stickers} contrib
+@item Consistent interactive button interface. Everything can be copied to
+ the REPL.
+@item Multiple inspectors with independent history
+@item Regexp-capable @code{M-x sly-apropos}
+@item Contribs are first class SLY citizens and enabled by default
+@item Use ASDF to loads contribs on demand.
+@end enumerate
+
+SLY tracks SLIME's bugfixes and all its familar features (debugger, inspector,
+xref, etc...) are still available, but with better integration.")
+ (license license:gpl3+))))
+
(define-public emacs-lua-mode
(let ((commit "652e299cb967fccca827dda381d61a9c144d97de")
(revision "1"))