summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMiguel Ángel Moreno <me@mianmoreno.com>2023-06-06 11:26:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-10 20:35:39 +0200
commitec66bd267fb750bd81d11601db37394fe62228b1 (patch)
treed88f41500a711a56ac3eac3e07ef6c90b5d3f0e8 /gnu/packages
parentc6d494e49fa5aa87d376a7e58c0d73067f6fad11 (diff)
gnu: emacs-ytdl: Update to 1.3.6-0.2ea3daf2.
* gnu/packages/emacs-xyz.scm (emacs-ytdl): Update to 1.3.6-0.2ea3daf2. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm70
1 files changed, 36 insertions, 34 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 950dd44b7d..86026c115a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26988,43 +26988,45 @@ can be queued at any time.")
(license license:unlicense))))
(define-public emacs-ytdl
- (package
- (name "emacs-ytdl")
- (version "1.3.6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/tuedachu/ytdl")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "010arhvibyw50lqhsr8bm0vj3pzry1h1vgcvxnmyryirk3dv40jl"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- ;; .el is read-only in git.
- (make-file-writable "ytdl.el")
- ;; Specify the absolute file names of the various programs so
- ;; that everything works out-of-the-box.
- (emacs-substitute-variables "ytdl.el"
- ("ytdl-command"
- (search-input-file inputs "/bin/youtube-dl"))))))))
- (inputs
- (list youtube-dl))
- (propagated-inputs
- (list emacs-async emacs-dash))
- (home-page "https://gitlab.com/tuedachu/ytdl")
- (synopsis "Emacs interface for youtube-dl")
- (description
- "This package manages a video download queue for @command{youtube-dl},
+ (let ((commit "2ea3daf2f6aa9d18b71fe3e15f05c30a56fca228")
+ (revision "0"))
+ (package
+ (name "emacs-ytdl")
+ (version (git-version "1.3.6" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/tuedachu/ytdl")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y62lkgsg19j05dpd6sp6zify8vq8xvpc8caqiy4rwi7p4ahacsf"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; .el is read-only in git.
+ (make-file-writable "ytdl.el")
+ ;; Specify the absolute file names of the various programs so
+ ;; that everything works out-of-the-box.
+ (emacs-substitute-variables "ytdl.el"
+ ("ytdl-command"
+ (search-input-file inputs "/bin/youtube-dl"))))))))
+ (inputs
+ (list youtube-dl))
+ (propagated-inputs
+ (list emacs-async emacs-dash))
+ (home-page "https://gitlab.com/tuedachu/ytdl")
+ (synopsis "Emacs interface for youtube-dl")
+ (description
+ "This package manages a video download queue for @command{youtube-dl},
which serves as the back end. New videos can be queued at any time. All
youtube-dl backends are supported. It is possible to create download profiles
depending on the downloaded URL.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-ytel
;; No tagged releases. Using version from main file.