summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-06-09 12:44:14 -0300
committerVinicius Monego <monego@posteo.net>2023-09-16 23:10:49 -0300
commitee17fdfe42daab9ef7849a2d204fc69179daf1bf (patch)
tree21802a9560d744c2bdbbe39a865fc9a40f0244a1 /gnu/packages
parent952a0ce2800e4fe9165184151412858ed8d34760 (diff)
gnu: python-typeguard: Add dependency on python-setuptools-scm.
* gnu/packages/python-xyz.scm (python-typeguard)[native-inputs]: Add python-setuptools-scm.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2230310a03..dd3f987475 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24125,8 +24125,10 @@ based on the CPython 2.7 and 3.7 parsers.")
;; XXX: These fail when installed as a library:
;; https://github.com/agronholm/typeguard/issues/176
"not usefixtures and not test_cached_module")))))))
- (native-inputs
- (list python-mypy python-pytest python-typing-extensions))
+ (native-inputs (list python-mypy
+ python-pytest
+ python-setuptools-scm
+ python-typing-extensions))
(home-page "https://github.com/agronholm/typeguard")
(synopsis "Run-time type checker for Python")
(description