summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-03-30 11:48:12 +0200
committerLars-Dominik Braun <lars@6xq.net>2023-03-30 11:54:31 +0200
commiteebb0bfd68a863f6ef6c18e20daad7aaa6d3ba2a (patch)
treefee4c13842b1b855a7e44a9272c63c2ef23841ef /gnu/packages
parentc10bfa888545fb03d70a46ec70a676c69e6e0587 (diff)
gnu: python-sip: Update to 6.7.7.
* gnu/packages/patches/python-sip-include-dirs.patch: New file. * gnu/local.mk: Add it. * gnu/packages/qt.scm (python-sip): Update to 6.7.7. [propagated-inputs]: Add python-ply. [source]: Use patch.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/python-sip-include-dirs.patch20
-rw-r--r--gnu/packages/qt.scm7
2 files changed, 24 insertions, 3 deletions
diff --git a/gnu/packages/patches/python-sip-include-dirs.patch b/gnu/packages/patches/python-sip-include-dirs.patch
new file mode 100644
index 0000000000..f2ef8fc1b2
--- /dev/null
+++ b/gnu/packages/patches/python-sip-include-dirs.patch
@@ -0,0 +1,20 @@
+Add an environment variable to python-sip that extends its search
+directories for .sip files.
+
+It seems that we cannot easily change the destination folder of these
+files though, so this variable must be set on a per-package basis (and
+non through search-path).
+
+--- sip/sipbuild/builder.py 2023-03-22 09:06:37.588792878 +0100
++++ sip/sipbuild/builder.py 2023-03-22 09:10:35.830181134 +0100
+@@ -254,6 +254,10 @@
+ os.path.join(project.target_dir,
+ project.get_bindings_dir()))
+
++ # Add extra bindings from environment for GNU Guix.
++ if 'SIP_INCLUDE_DIRS' in os.environ:
++ sip_include_dirs.extend(os.environ['SIP_INCLUDE_DIRS'].split(os.pathsep))
++
+ # Generate the sip.h file for the shared sip module.
+ copy_sip_h(abi_major_version, project.build_dir,
+ project.sip_module, version_info=project.version_info)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index eaedf97371..d06ef6bccc 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3196,7 +3196,7 @@ instances.")
(define-public python-sip
(package
(name "python-sip")
- (version "5.5.0")
+ (version "6.7.7")
(source
(origin
(method url-fetch)
@@ -3206,12 +3206,13 @@ instances.")
"/sip-" version ".tar.gz")))
(sha256
(base32
- "1idaivamp1jvbbai9yzv471c62xbqxhaawccvskaizihkd0lq0jx"))))
+ "1qm9q9lhfky5zvxxkssf4zdfv5k1zikji4hz80d48vdfm1pw1sfy"))
+ (patches (search-patches "python-sip-include-dirs.patch"))))
(build-system python-build-system)
(native-inputs
(list python-wrapper))
(propagated-inputs
- (list python-toml python-packaging))
+ (list python-toml python-packaging python-ply))
(home-page "https://www.riverbankcomputing.com/software/sip/intro")
(synopsis "Python binding creator for C and C++ libraries")
(description